Bug 6511 - wbinfo -g do not work against samba 4 dc
wbinfo -g do not work against samba 4 dc
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
unspecified
All Linux
: P3 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks: 6600
  Show dependency treegraph
 
Reported: 2009-06-27 06:13 UTC by Matthieu Patou
Modified: 2010-02-11 08:54 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2009-06-27 06:13:57 UTC
On a correctly configured s3.4.0rc1 server wbinfo -u works (and return the full list of users in the domain) wbinfo -g do not return any group.
Comment 1 Kai Blin 2009-06-28 02:11:42 UTC
Is this against a Samba PDC? If so, this might be a duplicate of bug #6504
Comment 2 Matthieu Patou 2009-06-28 07:56:13 UTC
It's against a Samba4 DC and even bultin groups are not shown.
Comment 3 Karolin Seeger 2009-06-30 07:59:26 UTC
(In reply to comment #1)
> Is this against a Samba PDC? If so, this might be a duplicate of bug #6504
> 

So it's not a duplicate of bug #6504.
Comment 4 Matthieu Patou 2009-08-06 16:29:08 UTC
It seems to be mostly s4 fault ... 
here is the S4 log says :

SearchRequest: basedn: [dc=SMB4,dc=TST]
SearchRequest: filter: [(&(objectCategory=group)(&(groupType:dn:1.2.840.113556.1.4.803:=-2147483648)(!(groupType:dn:1.2.840.113556.1.4.803:=1))))]
SearchRequest: scope: [SUB]
SearchRequest: attrs: [userPrincipalName]
SearchRequest: attrs: [sAMAccountName]
SearchRequest: attrs: [name]
SearchRequest: attrs: [objectSid]
ldb_request SUB dn=dc=SMB4,dc=TST filter=(&(objectCategory=group)(&(groupType:dn:1.2.840.113556.1.4.803:=-2147483648)(!(groupType:dn:1.2.840.113556.1.4.803:=1))))
ldb: ldb: dnAttributes extended match not supported yet
ldb: ldb: dnAttributes extended match not supported yet
ldb: ldb: dnAttributes extended match not supported yet

Comment 5 Guenther Deschner 2009-08-06 18:37:27 UTC
seems like a samba4 problem, reassigning.
Comment 6 Kai Blin 2009-08-10 08:57:47 UTC
Can you get me a debug level 5 log of this? As far as I can see list groups should be implemented on the s4 winbind side.
Comment 7 Kai Blin 2009-08-10 10:46:46 UTC
From the IRC conversation I gather this is s3 winbind on an s3 member machine talking to a s4 AD DC. Reassigning to abartlet.
Comment 8 Matthias Dieter Wallnöfer 2009-11-24 16:51:47 UTC
ekacnet, does this work now?
Comment 9 Andrew Bartlett 2009-11-24 19:37:04 UTC
I don't think this works yet, we have not added that matching rule to ldb yet. 
Comment 10 Matthias Dieter Wallnöfer 2010-02-11 08:54:26 UTC
Should be fixed/worked around by http://gitweb.samba.org/samba.git/?p=samba.git;a=commitdiff;h=14c4c2c735d6b263d167bf5255fcf60de2c91110