Bug 6510 - smbclient doesn't show 'Server-Comment-Workgroup-Master'
smbclient doesn't show 'Server-Comment-Workgroup-Master'
Status: CLOSED INVALID
Product: Samba 3.3
Classification: Unclassified
Component: Client tools
3.3.2
x86 Windows 2003
: P3 minor
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 08:01 UTC by Paul Cobbaut
Modified: 2009-08-10 05:58 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Cobbaut 2009-06-26 08:01:18 UTC
Hello (my first bug report)

I have set up Samba-server 3.3.2 on Ubuntu 9.04 (ubuntu904) and Samba server 3.0.33 on Red Hat Enterprise Linux 5.3 (rhel53). Both machines are in the same network with a fresh install of a Windows 2003 sp2 (w2003) server.

Both samba servers have a very minimal smb.conf:
[global]

[firstshareX]
path=/srv/samba/public

Both these commands work perfectly on rhel5 and ubuntu904:
smbclient -NL ubuntu904
smbclient -NL rhel5


This command fails with NT_STATUS_ACCESS_DENIED on rhel5 and ubuntu904:
smbclient -NL w2003


I thought the solution would be easy:
smbclient -L w2003 -U Administrator%password
but then the Server-Comment-Workgroup-Master fields all stay empty.


Two screenshots below that show the empty fields:
-------------------------------------------------
root@ubuntu904:/etc/samba# smbclient -V
Version 3.3.2
root@ubuntu904:/etc/samba# smbclient -L w2003 -U Administrator%password
Domain=[W2003] OS=[Windows Server 2003 3790 Service Pack 2] Server=[Windows Server 2003 5.2]

	Sharename       Type      Comment
	---------       ----      -------
	C$              Disk      Default share
	IPC$            IPC       Remote IPC
	ADMIN$          Disk      Remote Admin
Domain=[W2003] OS=[Windows Server 2003 3790 Service Pack 2] Server=[Windows Server 2003 5.2]

	Server               Comment
	---------            -------

	Workgroup            Master
	---------            -------





-------------------------------------------------
[root@RHEL53 backup]# smbclient -V
Version 3.0.33-3.7.el5
[root@RHEL53 backup]# smbclient -L w2003 -U administrator%password
Domain=[W2003] OS=[Windows Server 2003 3790 Service Pack 2] Server=[Windows Server 2003 5.2]

	Sharename       Type      Comment
	---------       ----      -------
	C$              Disk      Default share
	IPC$            IPC       Remote IPC
	ADMIN$          Disk      Remote Admin
Domain=[W2003] OS=[Windows Server 2003 3790 Service Pack 2] Server=[Windows Server 2003 5.2]

	Server               Comment
	---------            -------

	Workgroup            Master
	---------            -------




I google and searched in this bugzilla, but didn't find a solution. Set the severity to minor because everything else works fine.
Comment 1 Volker Lendecke 2009-08-06 10:58:21 UTC
This is perfectly normal if your W2k3 is not a local master browser. Please read about network browsing. Please re-open this bug if you confirmed that machine "w2003" is a local master browser for your network.

Thanks,

Volker
Comment 2 Paul Cobbaut 2009-08-10 05:58:04 UTC
Thank you.