Bug 6501 - packaging/RHEL/makerpms.sh is failing
packaging/RHEL/makerpms.sh is failing
Status: RESOLVED DUPLICATE of bug 6479
Product: Samba 3.0
Classification: Unclassified
Component: Packaging
3.0.35
Other Linux
: P3 normal
: none
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 15:05 UTC by dw6881pr
Modified: 2009-06-24 02:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dw6881pr 2009-06-23 15:05:07 UTC
the samba.spec file is out of date 

Missing references to mount.cifs and umount.cifs.

 gcc -o mount.cifs -O2 -g -D_GNU_SOURCE -Wall -D_GNU_SOURCE -D_LARGEFILE64_SOURCE mount.cifs.c
/tmp/ccpTpDGR.o: In function `main':
/usr/src/redhat/BUILD/samba-3.0.35/source/client/mount.cifs.c:1404: undefined reference to `unlock_mtab'
/usr/src/redhat/BUILD/samba-3.0.35/source/client/mount.cifs.c:1405: undefined reference to `lock_mtab'
/usr/src/redhat/BUILD/samba-3.0.35/source/client/mount.cifs.c:1451: undefined reference to `unlock_mtab'
/usr/src/redhat/BUILD/samba-3.0.35/source/client/mount.cifs.c:1413: undefined reference to `unlock_mtab'
collect2: ld returned 1 exit status
error: Bad exit status from /var/tmp/rpm-tmp.36860 (%build)



I modified the spec file to not build these 2 items anymore.
Afterwards i got errors related to cifs.upcall. Is this a new component that needs to be added?

here's a patch that I used to fix the problems that I encountered.
--- samba.spec.orig	2009-06-23 15:27:22.000000000 -0400
+++ samba.spec	2009-06-23 15:50:07.000000000 -0400
@@ -170,11 +170,6 @@
 make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" %{?_smp_mflags} \
 	all modules pam_smbpass
 
-## build the cifs fs mount helper
-cd client
-gcc  -o mount.cifs $RPM_OPT_FLAGS  -D_GNU_SOURCE -Wall -D_GNU_SOURCE -D_LARGEFILE64_SOURCE mount.cifs.c
-gcc  -o umount.cifs $RPM_OPT_FLAGS  -D_GNU_SOURCE -Wall -D_GNU_SOURCE -D_LARGEFILE64_SOURCE umount.cifs.c
-cd ..
 
 # Remove some permission bits to avoid to many dependencies
 cd ..
@@ -265,8 +260,6 @@
 install -m755 setup/smbprint $RPM_BUILD_ROOT%{_bindir}
 install -m644 setup/smbusers $RPM_BUILD_ROOT%{_sysconfdir}/samba/smbusers
 install -m644 setup/smb.conf $RPM_BUILD_ROOT%{_sysconfdir}/samba/smb.conf
-install -m755 source/client/mount.cifs $RPM_BUILD_ROOT/sbin/mount.cifs
-install -m755 source/client/umount.cifs $RPM_BUILD_ROOT/sbin/umount.cifs
 install -m755 source/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_bindir}
 
 /bin/rm $RPM_BUILD_ROOT%{_sbindir}/*mount.cifs
@@ -359,6 +352,7 @@
 %{_sbindir}/smbd
 %{_sbindir}/nmbd
 %{_sbindir}/winbindd
+%{_sbindir}/cifs.upcall
 
 %{_bindir}/mksmbpasswd.sh
 %{_bindir}/smbcontrol
@@ -393,6 +387,7 @@
 %{_mandir}/man1/wbinfo.1*
 %{_mandir}/man8/vfs_*.8*
 %{_mandir}/man8/idmap_*.8*
+%{_mandir}/man8/cifs.upcall.8*
 
 
 ##########
@@ -425,8 +420,6 @@
 %defattr(-,root,root)
 /sbin/mount.smb
 /sbin/mount.smbfs
-/sbin/mount.cifs
-/sbin/umount.cifs
 
 %{_bindir}/rpcclient
 %{_bindir}/smbcacls
Comment 1 Karolin Seeger 2009-06-24 02:11:25 UTC

*** This bug has been marked as a duplicate of bug 6479 ***