Bug 6432 - build system: cross-compilation may fail when host's and target's libc differ
build system: cross-compilation may fail when host's and target's libc differ
Status: RESOLVED WONTFIX
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
Other Linux
: P5 normal
: ---
Assigned To: Jelmer Vernooij
samba4-qa@samba.org
:
: 6433 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 10:22 UTC by Jonas Gorski
Modified: 2010-03-04 04:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Gorski 2009-06-02 10:22:55 UTC
Using the just released 3.4.0pre2:

The host build of heimdal fails when building with a glibc gcc as the hostcc and a uclibc gcc as the targetcc with:

Linking bin/asn1_compile
bin/mergedobj/replace_hostcc.o: In function `rep_mkstemp':
(.text+0x12): warning: the use of `mktemp' is dangerous, better use `mkstemp' or `mkdtemp'
bin/mergedobj/heimdal_roken_h.o: In function `print_arg':
getarg.c:(.text+0x7bd): undefined reference to `strlcat'
getarg.c:(.text+0x7d7): undefined reference to `strlcat'
getarg.c:(.text+0x7f9): undefined reference to `strlcat'
getarg.c:(.text+0x815): undefined reference to `strlcat'
getarg.c:(.text+0x8ac): undefined reference to `strlcat'
bin/mergedobj/heimdal_roken_h.o: In function `mandoc_template':
getarg.c:(.text+0x99e): undefined reference to `strlcpy'
bin/mergedobj/heimdal_roken_h.o: In function `arg_printusage_i18n':
(.text+0x1197): undefined reference to `strlcpy'
bin/mergedobj/heimdal_roken_h.o: In function `arg_printusage_i18n':
(.text+0x11d7): undefined reference to `strlcat'
bin/mergedobj/heimdal_roken_h.o: In function `arg_printusage_i18n':
(.text+0x1210): undefined reference to `strlcat'
bin/mergedobj/heimdal_roken_h.o: In function `arg_printusage_i18n':
(.text+0x12ba): undefined reference to `strlcat'
bin/mergedobj/heimdal_roken_h.o: In function `arg_printusage_i18n':
(.text+0x12f3): undefined reference to `strlcat'
bin/mergedobj/heimdal_roken_h.o: In function `arg_printusage_i18n':
(.text+0x1322): undefined reference to `strlcat'
bin/mergedobj/heimdal_roken_h.o:(.text+0x13c6): more undefined references to `strlcat' follow
bin/mergedobj/heimdal_roken_h.o: In function `parse_record':
resolve.c:(.text+0x3326): undefined reference to `__dn_expand'
resolve.c:(.text+0x34f6): undefined reference to `__dn_expand'
resolve.c:(.text+0x3585): undefined reference to `__dn_expand'
resolve.c:(.text+0x3661): undefined reference to `strlcpy'
resolve.c:(.text+0x3694): undefined reference to `__dn_expand'
resolve.c:(.text+0x37c0): undefined reference to `strlcpy'
resolve.c:(.text+0x39a7): undefined reference to `__dn_expand'
resolve.c:(.text+0x3c0e): undefined reference to `strlcpy'
bin/mergedobj/heimdal_roken_h.o: In function `parse_reply':
resolve.c:(.text+0x41b7): undefined reference to `__dn_expand'
bin/mergedobj/heimdal_roken_h.o: In function `dns_lookup_int':
resolve.c:(.text+0x44e3): undefined reference to `__res_search'
collect2: ld returned 1 exit status
make[3]: *** [bin/asn1_compile] Error 1

The problem seems to be that all availability tests for functions are only done for the target, but not for the host.
Comment 1 Jonas Gorski 2009-06-03 17:27:13 UTC
*** Bug 6433 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Dieter Wallnöfer 2009-07-29 10:58:29 UTC
Lower priority
Comment 3 Matthias Dieter Wallnöfer 2010-03-04 04:25:59 UTC
I as QA don't think that this will be fixed since our priorities don't lie in the cross-build area.
As the build log states, the problem happens in the heimdal part of the build (where we aren't responsible - you had to contact the upstream project "KERBEROS Heimdal" (www.h5l.org) to fix that). But then I think also more and more problems in our code will appear.

So if you really need this - you will need to provide us patches. I close this with "WONTFIX" unless I hear again from you.