Bug 6423 - Limit maximum simultaneous connection
Limit maximum simultaneous connection
Status: RESOLVED DUPLICATE of bug 3204
Product: Samba 3.6
Classification: Unclassified
Component: Winbind
All All
: P3 enhancement
: ---
Assigned To: Volker Lendecke
Samba QA Contact
Depends on: 3204
  Show dependency treegraph
Reported: 2009-05-31 01:24 UTC by Zhou Weikuan
Modified: 2014-08-28 07:07 UTC (History)
3 users (show)

See Also:

winbindd.diff (1.08 KB, patch)
2009-05-31 01:27 UTC, Zhou Weikuan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zhou Weikuan 2009-05-31 01:24:37 UTC
From the code, winbindd planned to limit the max simuteneous clients into WINBINDD_MAX_SIMULTANEOUS_CLIENTS, but it does open connection each time. The attached patch is to finish this. 

This is for origin/v3-4-test, if you want to add personal copyright, please use the following one:
Copyright (C) David Daugherty 2009
Comment 1 Zhou Weikuan 2009-05-31 01:27:06 UTC
Created attachment 4223 [details]

I'm new to git, the wiki doesn't tell how to generate a patch, so I used:
git-diff > file.diff
Comment 2 Volker Lendecke 2009-05-31 02:54:17 UTC
Do we really want this? I've got patches in the queue that make winbind use epoll instead of select, so many clients should be MUCH less of a problem in the future.

Comment 3 Zhou Weikuan 2009-05-31 20:38:44 UTC
OK. So you will remove or enlarge WINBINDD_MAX_SIMULTANEOUS_CLIENTS?
Comment 4 Volker Lendecke 2009-06-02 05:55:19 UTC
When that patch is in (post-3.4), then yes, I think we could probably remove that limit or limit it to something like 10000 or some silly high value to protect against a DoS. We'll also make the in-winbind representation of an idle client as cheap as possible.

Comment 5 Karolin Seeger 2009-07-01 09:38:07 UTC
Updating component as this won't change in 3.4.
Assigning bug to Volker as he is working on that one.
Comment 6 Karolin Seeger 2010-01-25 05:33:17 UTC
Too late for enhancements in 3.5. Raise version.
Comment 7 Björn Jacke 2014-07-24 20:36:09 UTC
Zhou: this is not a problem for you with latest samba releases, right?
Volker: this is ready to be close from your point of view?
Comment 8 Volker Lendecke 2014-07-25 08:33:41 UTC
(In reply to comment #7)
> Zhou: this is not a problem for you with latest samba releases, right?
> Volker: this is ready to be close from your point of view?

No, it's not done yet. We can lift the 200 client limit for sure, but we definitely need a hard limit significantly below the number of file descriptors we are allowed to open.
Comment 9 Stefan Metzmacher 2014-08-28 07:07:04 UTC

*** This bug has been marked as a duplicate of bug 3204 ***