Bug 638 - make : *** (dynconfig.o) error 1 msg after make command.
make : *** (dynconfig.o) error 1 msg after make command.
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0preX
All other
: P3 normal
: none
Assigned To: Jim McDonough
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 09:17 UTC by John Gardner
Modified: 2005-11-14 09:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Gardner 2003-10-16 09:17:17 UTC
Downloaded Samba-latest.tar.gz dated Sep 25 02:53 ; 
(not sure which version of 3.0.0 this actually is)!
I uploaded the tar ball into a Suse Linux system...
(SLES8) system running under VM on S390.Installed GNU C++ compiler from the 
Suse (SLES8) Cd.Ran ./config command then tried the 'make' which gave the 
following msgs (logged in as 'root').
after 'Compiling dynconfig.c'.....I get ....
/usr/include/asm-s390/statfs.h:20: redefinition of 'struct statfs' .....
make: *** (dynconfig.o) Error 1
Comment 1 Gerald (Jerry) Carter 2003-11-04 20:11:41 UTC
Jim, can you look at this since it is an s390 issue?  Thanks.
Comment 2 Jim McDonough 2003-11-05 05:45:20 UTC
John, did you try:
./autogen.sh
before running configure?

This is certainly odd, because I just ran this (just ./configure, not running
./autogen.sh first) on a SLES 8 system, and while I didn't wait for the whole
build to complete, it certainly has compiled quite a few source files with no
problems.  I'm running SLES 8, kernel 2.4.19-3suse-SMP (390), gcc-3.2-34,
glibc-2.2.5-87 (and -devel at same level).

Can you give some more info here, like the packages I mention above, and also if
it mentions where "struct statfs" is first defined?
Comment 3 Gerald (Jerry) Carter 2003-11-12 20:41:45 UTC
firstly,no I did'nt run autogen before configure.
As for the package info,I can confirm that we are running SLES8,kernel
2.4.19-3suse-SMp (root@s390zo2), and gcc version 3.2.
Sorry,but I ca'nt supply any glibc or -devel levels,as I no longer have the
Linux environment with the latest samba installed in it ; I have since
installed a prior Samba
(2.2.5) version as distrubuted with the Suse CD (but I have'nt got it
working yet)!
Comment 4 Jim McDonough 2003-11-13 07:01:50 UTC
So from what you describe, this is a problem with glibc-devel, not samba.  Samba
cannot patch glibc-devel include files, and apparently SuSE is aware of this. 
I'm curious to know what level of glibc-devel this is failing on, because on my
level (2.2.5-87) the mentioned include file is #ifdef protected, and I'd like to
make sure that SuSE is fixing it (either they already have and I've got the fix,
or they've broken in since mine).
Comment 5 Gerald (Jerry) Carter 2005-02-07 07:57:22 UTC
originally reported against 3.0aph24.  Bugzilla spring cleaning.  
Removing old alpha versions.
Comment 6 Gerald (Jerry) Carter 2005-11-14 09:25:32 UTC
database cleanup