Bug 637 - Users can't log in
Users can't log in
Status: RESOLVED WONTFIX
Product: Samba 2.2
Classification: Unclassified
Component: smbclient
2.2.0
Other HP-UX
: P2 major
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 07:53 UTC by Donovan Scott
Modified: 2004-02-17 08:56 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Donovan Scott 2003-10-16 07:53:45 UTC
At a production site, (a hospital), we have users logging into our application 
on an HP server running HP-UX 11.11 and Samba 2.2.0 to get to the files.  In 
the last two days they have gone down three times where users have been unable 
to log in, and the solution was restarting Samba completely.  I see these 
errors a lot:

[2003/10/16 08:08:27, 0] smbd/oplock.c:request_oplock_break(995)
  request_oplock_break: no response received to oplock break request to pid 
17065 on port 64187 for dev = 40010001, inode = 11634
  for dev = 40010001, inode = 11634, tv_sec = 3f8e6dbb, tv_usec = e3351

We were originally running nmbd and smbd through inetd, and I tried running 
them as daemons yesterday with nmbd -D and smbd -D, and it has gone down both 
ways.  This is a hospital emergency dept. that has to be up 24/7/365, so I am 
trying to figure out what to do.  I don't know if this is a Samba or OS 
problem.  It has gone down with 50 smbd processes running and 159 processes 
running.  I searched through Google and saw no solutions.
Comment 1 Gerald (Jerry) Carter 2003-10-16 08:17:59 UTC
oplock break error messages are normally the result 
of bad networking hardware such as flakey hubs, etc...

However 2.2.0 is really old and has known bugs
and security holes.  So an upgrade in the near 
future would be in your best interest.

Other than that, you not really given any 
information as to why you think that there is a bug 
in Samba causing this.  Have you tried working
with people on the Samba mailing list to weed out
any configuration issues?
Comment 2 Gerald (Jerry) Carter 2004-02-17 08:56:08 UTC
Sorry, but the 2.2 is not under development any longer.
If you can reproduce this bug against the latest 3.0 release, 
please reopen this bug and change the version in the report.
Thanks.