Bug 6354 - force user not working
force user not working
Status: RESOLVED DUPLICATE of bug 6291
Product: Samba 3.2
Classification: Unclassified
Component: File services
x64 Windows XP
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2009-05-12 20:20 UTC by Mark Orenstein
Modified: 2009-05-14 05:56 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Mark Orenstein 2009-05-12 20:20:32 UTC
Last month, I updated to Fedora 10 with samba 3.2.11-0.30.fc10 via a
complete reinstall. Using x86-64.  We are now experiencing a problem on a
share with the force user parameter.  Samba is a domain controller.  Still using smbuser file

        comment = Test Share
        path = /home/zz
        force user = zzadminp
        create mask = 0770
        directory mask = 0770

The primary group of zzadminp above is admplus.

If user markoren with primary group ntadmin writes a file to the above
share, the file owner is markoren and the file group is admplus.

-rwxrw---- 1 markoren admplus 94 2009-05-12 19:51 MAOtestfilezz8.txt

Samba is setting the primary group of the forced user properly, but is not
setting the forced user as the owner.

Mark Orenstein
East Granby School System (USA)
Comment 1 Mark Orenstein 2009-05-14 05:56:29 UTC

*** This bug has been marked as a duplicate of bug 6291 ***