Bug 6335 - Samba share is disconnecting
Samba share is disconnecting
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.28
Other Linux
: P3 regression
: none
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 11:11 UTC by Harika
Modified: 2009-05-20 11:13 UTC (History)
0 users

See Also:


Attachments
Wireshark report (143.07 KB, image/pjpeg)
2009-05-11 12:31 UTC, Harika
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harika 2009-05-06 11:11:00 UTC
Hi,

On Z Linux we have installed samba-3.0.28-0.5

We have created a share for this in Z Linux machine. We have mapped this samba share folder to a windows server 2003. 
From windows machine we are runing some file copy tests which creates, read, write files into samba shared directory. The Linux samba share is getting disconnected from windows machine inturn our tests are failing.

I can see the below log messages in samba logs

2009/05/06 10:45:04, 2] smbd/close.c:close_normal_file(406)
  root closed file clients/client2/~dmtmp/PARADOX/STUDENTS.XG0 (numopen=0) NT_STATUS_OK
[2009/05/06 10:45:04, 3] smbd/sec_ctx.c:set_sec_ctx(241)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2009/05/06 10:45:04, 1] smbd/service.c:close_cnum(1230)
  zlinux-perf-nb1 (192.168.69.245) closed connection to service samba
[2009/05/06 10:45:04, 3] smbd/connection.c:yield_connection(69)
  Yielding connection to samba
[2009/05/06 10:45:04, 3] smbd/sec_ctx.c:set_sec_ctx(241)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2009/05/06 10:45:04, 3] smbd/connection.c:yield_connection(69)
  Yielding connection to
[2009/05/06 10:45:04, 3] smbd/server.c:exit_server_common(768)
  Server exit (normal exit)



This share is not disconnecting always, only some times it is happening.
Please help me with this issue, why the share is disconnecting.
Comment 1 Volker Lendecke 2009-05-07 04:36:07 UTC
This looks like a perfectly normal client-triggered exit. Can you please post your smb.conf and a full debug level 10 log of smbd when it has problems, together with a network trace? Information on how to create useful network traces can be found under http://wiki.samba.org/index.php/Capture_Packets

Thanks,

Volker
Comment 2 Harika 2009-05-07 12:33:03 UTC
Thanks For your reply

I have increased the debug level to 10. I am attaching the logs for the same

************************************************************************

[2009/05/07 13:14:13, 4] nmbd/nmbd_packets.c:process_dgram(1276)
  process_dgram: datagram from ZLINUX-PERF-SP<20> to WORKGROUP<1e> IP 9.12.34.244 for \MAILSLOT\BROWSE of type 15 len=33
[2009/05/07 13:14:13, 8] lib/util.c:is_myname(2076)
  is_myname("ZLINUX-PERF-SP") returns 0
[2009/05/07 13:14:13, 4] nmbd/nmbd_packets.c:debug_browse_data(100)
  debug_browse_data():
    0 char ......ZLINUX-PER hex 0f 00 80 fc 0a 00 5a 4c 49 4e 55 58 2d 50 45 52
   10 char F-SP..........U. hex 46 2d 53 50 00 00 05 02 07 90 84 00 0f 01 55 aa
   20 char .                hex 00
[2009/05/07 13:14:13, 3] nmbd/nmbd_incomingdgrams.c:process_local_master_announce(274)
  process_local_master_announce: from ZLINUX-PERF-SP<00> IP 9.12.34.244 to WORKGROUP<1e> for server ZLINUX-PERF-SP.
[2009/05/07 13:14:13, 5] nmbd/nmbd_incomingdgrams.c:process_local_master_announce(277)
  process_local_master_announce: ttl=720 server type=00849007 comment=
[2009/05/07 13:14:13, 4] nmbd/nmbd_workgroupdb.c:find_workgroup_on_subnet(171)
  find_workgroup_on_subnet: workgroup search for WORKGROUP on subnet 9.12.34.231: found.
[2009/05/07 13:14:13, 8] lib/util.c:is_myname(2076)
  is_myname("ZLINUX-PERF-SP") returns 0
[2009/05/07 13:14:13, 5] nmbd/nmbd_become_lmb.c:set_workgroup_local_master_browser_name(577)
  set_workgroup_local_master_browser_name: setting local master name to 'ZLINUX-PERF-SP' for workgroup WORKGROUP.
[2009/05/07 13:14:13, 4] nmbd/nmbd_workgroupdb.c:find_workgroup_on_subnet(171)
  find_workgroup_on_subnet: workgroup search for WORKGROUP on subnet 9.12.34.231: found.
[2009/05/07 13:14:13, 4] nmbd/nmbd_workgroupdb.c:find_workgroup_on_subnet(171)
  find_workgroup_on_subnet: workgroup search for WORKGROUP on subnet 192.168.69.231: found.
[2009/05/07 13:14:13, 10] nmbd/nmbd_sendannounce.c:announce_myself_to_domain_master_browser(372)
  announce_myself_to_domain_master_browser: no unicast subnet, ignoring.
[2009/05/07 13:14:23, 4] nmbd/nmbd_workgroupdb.c:find_workgroup_on_subnet(171)
  find_workgroup_on_subnet: workgroup search for WORKGROUP on subnet 9.12.34.231: found.
[2009/05/07 13:14:23, 4] nmbd/nmbd_workgroupdb.c:find_workgroup_on_subnet(171)
  find_workgroup_on_subnet: workgroup search for WORKGROUP on subnet 192.168.69.231: found.
[2009/05/07 13:14:23, 10] nmbd/nmbd_sendannounce.c:announce_myself_to_domain_master_browser(372)
  announce_myself_to_domain_master_browser: no unicast subnet, ignoring.

******************************************************************************

I have ran the wireshark tool.The last packet is transfered from windows machine to linux machine(samba share). This has failed due to checksum error.

Comment 3 Volker Lendecke 2009-05-08 01:40:54 UTC
That's a log of nmbd, not of smbd. And please upload the wireshark trace itself, don't describe what you see please :-)

Volker
Comment 4 Volker Lendecke 2009-05-11 10:12:36 UTC
Any updates here?

Volker
Comment 5 Harika 2009-05-11 12:31:09 UTC
Created attachment 4140 [details]
Wireshark report

The logs that i have attached are for smbd only.nmbd logs are different.
I am attaching the last request of wireshark report.THis request has sent from windows machine to linux share.
Comment 6 Volker Lendecke 2009-05-15 14:13:36 UTC
Sorry, this is again not the output that we need. Please save the capture using the file->save dialogue in wireshark.

Thanks,

Volker
Comment 7 Harika 2009-05-20 11:13:38 UTC
We have found out the issue is with network, So i am closing the bug