Bug 6312 - rsync -X does not preserve SELinux context
rsync -X does not preserve SELinux context
Status: RESOLVED DUPLICATE of bug 5356
Product: rsync
Classification: Unclassified
Component: core
3.0.5
Other Linux
: P3 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-01 07:13 UTC by morgan read
Modified: 2009-11-21 00:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description morgan read 2009-05-01 07:13:53 UTC
Source
$ uname -r
2.6.27.21-170.2.56.fc10.i686
$ rpm -q rsync
rsync-3.0.5-1.fc10.i386
Target
# uname -r
2.6.26.8-57.fc8
# rpm -q rsync
rsync-2.6.9-5.fc8


Description is the same as:
https://bugzilla.samba.org/show_bug.cgi?id=5356

I would have re-opened that if I could have, but a new bug gives the opportunity to provide a better Summary, same as:
https://bugzilla.redhat.com/show_bug.cgi?id=458014

Re the reason for closing bug 5356:
I don't see "that the "lsetxattr"
failure is caused by a fundamental change in the file system data structures
implementing extended SELinux file attributes between Linux kernels" 2.6.26 and
2.6.27, which seems the implication of the reason for closing the bug.
Comment 1 morgan read 2009-05-01 07:15:30 UTC
Here's a couple of links to my rsync list posts:
http://lists.samba.org/archive/rsync/2009-April/022996.html
http://lists.samba.org/archive/rsync/2009-April/023150.html
Comment 2 Matt McCutchen 2009-11-21 00:50:22 UTC
(In reply to comment #0)
> Re the reason for closing bug 5356:
> I don't see "that the "lsetxattr"
> failure is caused by a fundamental change in the file system data structures
> implementing extended SELinux file attributes between Linux kernels" 2.6.26 and
> 2.6.27, which seems the implication of the reason for closing the bug.

The above has been refuted at
https://bugzilla.redhat.com/show_bug.cgi?id=458014#c4 :
> You have to understand that SELinux labels are not defined in the kernel, but
> *loaded* in the kernel at startup sourcing from the policy files.

I.e., this is most likely caused by an incompatibility in the SELinux policy and is no fault of rsync, just like bug 5356.  Please reopen if you have evidence to the contrary.

*** This bug has been marked as a duplicate of bug 5356 ***