Bug 6306 - wbinfo -u/-g return nothing with a 3.4pre1 Domain Controller
wbinfo -u/-g return nothing with a 3.4pre1 Domain Controller
Status: RESOLVED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: User & Group Accounts
unspecified
Other Linux
: P3 regression
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 10:45 UTC by David Markey
Modified: 2009-07-20 02:22 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Markey 2009-04-30 10:45:47 UTC
Server: 3.4pre1 smbpasswd backend, PDC mode, debian5 i386

Client: 3.4pre1, debian5 i386.

Client successfully joined the domain,

wbinfo -n david successfully returns to SID of david.

However wbinfo -u and -g return nothing.

http://dmarkey.com/~dmarkey/samba3.4pre1/client34.log
http://dmarkey.com/~dmarkey/samba3.4pre1/server34.log



Exact same behavior with a Centos53 client(3.0.33-3.7.el5).
Comment 1 Guenther Deschner 2009-05-06 06:11:48 UTC
Ok, this is again a problem with the samr access checks. (denies remote user and group enumeration).
Comment 2 Guenther Deschner 2009-05-19 03:23:57 UTC
A master/v3-4-test PDC should be all fine now again for domain members running winbind (no matter what version). Can you please give this a test?
Comment 3 Guenther Deschner 2009-06-11 17:05:27 UTC
3.4.0pre2 should be fine already.

Please reopen if still an issue.
Comment 4 Marc Muehlfeld 2009-07-20 02:22:05 UTC
Is this something similar or the same like I descriped in
https://bugzilla.samba.org/show_bug.cgi?id=6504
If yes, the problem is still there in 3.4.0 final.