Bug 6299 - Samba 3.4 fails to join a Samba4 domain
Samba 3.4 fails to join a Samba4 domain
Status: RESOLVED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: Domain Control
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Stefan Metzmacher
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 01:31 UTC by Matthieu Patou
Modified: 2009-06-19 07:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2009-04-29 01:31:34 UTC
/usr/local/samba/bin/net --version
Version 3.4.0-GIT-d8f3f7c-devel

On the samba 3.4 server:

libnet_join_ok: failed to get schannel session key from server test.smb4.tst for domain SAMBA4. Error was NT_STATUS_ACCESS_DENIED
Failed to join domain: failed to verify domain membership after joining: Access denied


In the samba4 server logs (Version 4.0.0alpha7 works OK with XP workstations)
[Wed Apr 29 10:25:20 2009 MSD, 2 auth/ntlm/auth.c:371:auth_check_password_recv()]                                   
auth_check_password_recv: sam_ignoredomain authentication for user [SAMBA4\SMBFSVZ01$] FAILED with error NT_STATUS_WRONG_PASSWORD                                 
[Wed Apr 29 10:25:20 2009 MSD, 2 auth/gense/spnego.c:706:gensec_spnego_server_negTokenTarg()]            
SPNEGO login failed: NT_STATUS_WRONG_PASSWORD
Comment 1 Stefan Metzmacher 2009-05-29 03:25:56 UTC
If I remember correctly 3.4.0-GIT-d8f3f7c-devel (from late april)
was broken (it would also not join a windows domain).
I think it was fixed again in d9805878e242d0d279f340b4a1fd084c77f240b1.

Could you retest with a current version?
Comment 2 Guenther Deschner 2009-06-17 05:49:20 UTC
any updates on this ?
Comment 3 Matthieu Patou 2009-06-19 07:25:31 UTC
I tried with git version: ed5c270b750ce736155a4e02fc7d2c51fe6b8c2a and it works now !

Closing the bug!