Bug 6267 - invalid free in _nss_nis_getpwnam_r
invalid free in _nss_nis_getpwnam_r
Status: RESOLVED INVALID
Product: Samba 3.2
Classification: Unclassified
Component: libsmbclient
3.2.7
x64 Linux
: P3 regression
: ---
Assigned To: Derrell Lipman
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-16 03:58 UTC by Bruno Escherl
Modified: 2009-04-16 05:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Escherl 2009-04-16 03:58:06 UTC
*** glibc detected *** ./seamonkey-bin: free(): invalid pointer: 0x00007f70bd11d8d0 ***
======= Backtrace: =========
/lib64/libc.so.6[0x7f70c0c62118]
/lib64/libc.so.6(cfree+0x76)[0x7f70c0c63c76]
/lib64/libnss_nis.so.2(_nss_nis_getpwnam_r+0x101)[0x7f70bca76381]
/lib64/libnss_compat.so.2[0x7f70bcc7f16b]
/lib64/libnss_compat.so.2(_nss_compat_getpwnam_r+0x227)[0x7f70bcc7f437]
/lib64/libc.so.6(getpwnam_r+0xed)[0x7f70c0c8ea7d]
/usr/lib64/libglib-2.0.so.0[0x7f70c1eca84c]
/usr/lib64/libglib-2.0.so.0(g_get_home_dir+0xb5)[0x7f70c1ecc265]
/usr/lib64/libgtk-x11-2.0.so.0[0x7f70c3ffcac6]
/usr/lib64/libgtk-x11-2.0.so.0[0x7f70c3fff38d]
/usr/lib64/libgtk-x11-2.0.so.0[0x7f70c3fb6c25]
/usr/lib64/libglib-2.0.so.0(g_option_context_parse+0x587)[0x7f70c1ea5d87]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_parse_args+0x9f)[0x7f70c3fb68ef]
./libxul.so(XRE_main+0x855)[0x7f70c51e452b]
./seamonkey-bin[0x401bc7]
/lib64/libc.so.6(__libc_start_main+0xe6)[0x7f70c0c0c586]
./seamonkey-bin[0x401999]

Crash happens with newer SeaMonkey and Firefox builds, only occurs since Update from OpenSuse 11.0 to 11.1.

Samba Version used is 3.2.7-11.2.1-2080-SUSE-CODE11

It's not fully reproducable, sometimes it works after a reboot, sometime it crashes. Perhaps related to bug 5904?
Comment 1 Guenther Deschner 2009-04-16 04:52:27 UTC
What makes you think Samba is related to this crash ?
Comment 2 Bruno Escherl 2009-04-16 05:14:52 UTC
Isn't libnss_nis part of samba?

Another reason is, my original bug at https://bugzilla.mozilla.org/show_bug.cgi?id=488541 was duped against another bug, where the culprit seems to be bug 5904.
Comment 3 Guenther Deschner 2009-04-16 05:30:52 UTC
(In reply to comment #2)
> Isn't libnss_nis part of samba?

Ah, no. NIS is not part of Samba :)

I suggest to open a bug in the suse bugzilla about this.