Bug 626 - Filetimes do not support microsecond resolution
Filetimes do not support microsecond resolution
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.1
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 04:21 UTC by Torsten Martinsen
Modified: 2005-11-14 09:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Martinsen 2003-10-15 04:21:59 UTC
When using XCOPY /D from an NTFS driver to a Samba share, the timestamp 
resolution is limited to one second:

c:\user\appl\TortoiseCVSGH-1.4.5:
        Written: 01c37cf5:0d1565e6      2003/09/17 08:24:02.484

s:\tma\user\appl\TortoiseCVSGH-1.4.5:
        Written: 01c37cf5:0ccb7d00      2003/09/17 08:24:02.000

I think this may not be fixable, since utime(2) does not support time stamp 
resolution below one seconds. Still, this would improve compatibility with 
Windows servers.
Comment 1 Gerald (Jerry) Carter 2004-02-17 08:55:56 UTC
Sorry, but the 2.2 is not under development any longer.
If you can reproduce this bug against the latest 3.0 release, 
please reopen this bug and change the version in the report.
Thanks.
Comment 2 Torsten Martinsen 2004-02-18 02:43:54 UTC
Confirmed on Samba 3.0.1-Debian (Samba share on reiserfs volume), client W2K 
Professional Service Pack 4:

C:\user\tid>xcopy *.* q:\testing /r/s/k/d/y
C:ghtrproj.ini
C:tma.tid
C:tma.tid~
3 File(s) copied

C:\user\tid>xcopy *.* q:\testing /r/s/k/d/y
C:tma.tid
1 File(s) copied

C:\user\tid>xcopy *.* q:\testing /r/s/k/d/y
C:tma.tid
1 File(s) copied

C:\user\tid>dumptime q:\testing\tma.tid
q:\testing\tma.tid:
        Created: 01c3f605:771a7d80      2004/02/18 09:56:23.000
        Accessed: 01c3f605:771a7d80     2004/02/18 09:56:23.000
        Written: 01c3f605:771a7d80      2004/02/18 09:56:23.000

C:\user\tid>dumptime tma.tid
tma.tid:
        Created: 01c3bf23:9965ac66      2003/12/10 13:43:31.484
        Accessed: 01c3f605:77455e10     2004/02/18 09:56:23.281
        Written: 01c3f605:77455e10      2004/02/18 09:56:23.281

----------------------------------------------------------------------------

linux1:/home/data/uback/testing# ll
total 108
-rw-rw-r--    1 GATEHOUSE+tma users        1878 Nov 26 23:32 ghtrproj.ini
-rw-rw-r--    1 GATEHOUSE+tma users       49500 Feb 18 10:56 tma.tid
-rw-rw-r--    1 GATEHOUSE+tma users       49500 Jan 13 13:14 tma.tid~
Comment 3 Gerald (Jerry) Carter 2004-03-08 09:08:45 UTC
can't fix without file system support.
Comment 4 Gerald (Jerry) Carter 2004-03-08 09:35:22 UTC
forgot to mark as resolved.
Comment 5 Gerald (Jerry) Carter 2005-11-14 09:30:43 UTC
database cleanup