Bug 6256 - Winbind dumps core with signal 6
Winbind dumps core with signal 6
Status: RESOLVED INVALID
Product: Samba 3.3
Classification: Unclassified
Component: Winbind
3.3.3
x86 FreeBSD
: P3 critical
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 07:32 UTC by Rashid N. Achilov
Modified: 2009-05-26 05:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rashid N. Achilov 2009-04-13 07:32:12 UTC
Periodically winbind dumps core with signal 6 with this fault report:

Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]: [2009/04/12 00:50:00,  0] lib/fault.c:fault_report(40)
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:   ===============================================================
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]: [2009/04/12 00:50:00,  0] lib/fault.c:fault_report(41)
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:   INTERNAL ERROR: Signal 6 in pid 16171 (3.3.3)
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:   Please read the Trouble-Shooting section of the Samba3-HOWTO
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]: [2009/04/12 00:50:00,  0] lib/fault.c:fault_report(43)
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:   
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:   From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]: [2009/04/12 00:50:00,  0] lib/fault.c:fault_report(44)
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:   ===============================================================
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]: [2009/04/12 00:50:00,  0] lib/util.c:smb_panic(1673)
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:   PANIC (pid 16171): internal error
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]: [2009/04/12 00:50:00,  0] lib/util.c:log_stack_trace(1777)
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:   BACKTRACE: 24 stack frames:
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #0 0x132435 <smb_panic+133> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #1 0x11acfa <dump_core_setup+1610> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #2 0xbfbfffb4
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #3 0x2090fcc9 <abort+105> at /lib/libc.so.7
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #4 0x208f7426 <__assert+86> at /lib/libc.so.7
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #5 0x207fbc5b <ldap_parse_result+859> at /usr/local/lib/libldap-2.4.so.6
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #6 0x3ec7a0 <ads_clear_service_principal_names+2336> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #7 0x3ecb59 <ads_do_search_all_args+105> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #8 0x3f966e <ads_atype_map+1246> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #9 0x3f9fda <ads_do_search_retry+58> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #10 0x3e89e9 <ads_USN+105> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #11 0x8ccc5 <winbindd_wins_byip+19861> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #12 0x70929 <wcache_count_cached_creds+1113> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #13 0x70d3b <cache_name2sid+171> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #14 0x71ce6 <nss_get_info_cached+2902> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #15 0x80c89 <winbindd_dual_list_trusted_domains+185> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #16 0x94892 <winbind_msg_online+8338> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #17 0x9545a <async_request+538> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #18 0x6a4d2 <init_child_connection+658> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #19 0x956e7 <async_domain_request+295> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #20 0x6a71f <init_child_connection+1247> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #21 0x6abc2 <rescan_trusted_domains+82> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #22 0x5fdda <main+3114> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:    #23 0x5d8ac <_start+140> at /usr/local/sbin/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]: [2009/04/12 00:50:00,  0] lib/fault.c:dump_core(231)
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]:   dumping core in /var/log/samba/cores/winbindd
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 winbindd[16171]: 
Apr 12 00:50:00 svr-63 kernel: Apr 12 00:50:00 svr-63 kernel: pid 16171 (winbindd), uid 0: exited on signal 6 (core dumped)

Samba 3.3.3 with fixes against bug #6238. Core file exist, I can download it on request.
Comment 1 Rashid N. Achilov 2009-04-17 02:59:34 UTC
Some more detalis about crash. That was done when 

[2009/04/17 01:40:00,  3] winbindd/winbindd_ads.c:enum_dom_groups(280)
  ads: enum_dom_groups
Assertion failed: (r != NULL), function ldap_parse_result, file error.c, line 272.
[2009/04/17 01:40:00,  0] lib/fault.c:fault_report(40)

issued.

Looking at source file winbindd_ads.c, I have seen, that IMHO was occured when line 

        rc = ads_search_retry(ads, &res, filter, attrs);

issued (line 327). I'll try do add extremely debug prints and test again
Comment 2 Volker Lendecke 2009-04-17 03:05:36 UTC
A network trace would also be very helpful. Information on how to create network traces can be found on http://wiki.samba.org/index.php/Capture_Packets.

Volker
Comment 3 Rashid N. Achilov 2009-04-17 04:15:35 UTC
I cannot reproduce this bug manually, so I'll simply start tcpdump today at evening
Comment 4 Volker Lendecke 2009-05-08 04:59:42 UTC
Any updates here? Does it still happen?

Volker
Comment 5 Volker Lendecke 2009-05-15 15:23:12 UTC
Closing. Please re-open if you can reproduce and upload a network trace.

Thanks,

Volker
Comment 6 Rashid N. Achilov 2009-05-26 05:11:33 UTC
This bug was fixed after upgrading at 3.3.4