Bug 6239 - NTFS logical drive in extended partion
NTFS logical drive in extended partion
Status: RESOLVED INVALID
Product: Samba 3.2
Classification: Unclassified
Component: File services
3.2.3
x86 Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 17:14 UTC by Helmut Ennsbrunner
Modified: 2009-05-13 04:34 UTC (History)
1 user (show)

See Also:


Attachments
Level 10 log file (24.06 KB, text/plain)
2009-04-02 16:52 UTC, Helmut Ennsbrunner
no flags Details
Level 10 log file without log size limit (152.43 KB, text/plain)
2009-04-03 14:43 UTC, Helmut Ennsbrunner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Ennsbrunner 2009-03-31 17:14:24 UTC
Hello

I encountered the following problem on my Ubuntu 8.10 using Samba 3.2.3:

I want to share two ntfs partions - one is a primary partion (sda4), the second one is a logical drive (sda5) in an extended partion (the primary partion is physical after the extended partion on the disk). On both partions I have read/write access on ubuntu.

fstab:
# /dev/sda5
UUID=645CF7E35CF7ADC4 /ntfsdata       ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda4
UUID=50C350FE04562A52 /ntfsmedia      ntfs    defaults,umask=007,gid=46 0       1

If I share them using samba, I am only able to write on the extended partion despite the fact that both mountpoints are equally entered in 

smb.conf:
[ntfsmedia]
	writeable = yes
	path = /ntfsmedia

[ntfsdata]
	writeable = yes
	path = /ntfsdata

This strange behaviour seems to be a bug in samba, as I can use them without any problem in the system. 
Unfortunately I did not find a similar problem in other bug reports.

Kind regards

Helmut

P.S.: this is my first report on Bugzilla - so I hope that I made everything alright.
Comment 1 Jeremy Allison 2009-04-01 12:30:15 UTC
Can you add a debug level 10 log of the writes failing please ?
Jeremy.
Comment 2 Helmut Ennsbrunner 2009-04-02 16:52:33 UTC
Created attachment 4046 [details]
Level 10 log file

I tried 2 times to create a new directory on the ntfs partion 'ntfsdata'. It fail with the error message: "Error while creating directory - Read-only file system".
Another ntfs partion 'ntfsmedia', which is a primary partion, causes no error during the same operation!

P.S.: I added in smb.conf under [global] the following lines
	# Debug logging information
	log level = 10
#	log file = /var/log/samba.log.%m
	max log size = 50
	debug timestamp = yes
Comment 3 Volker Lendecke 2009-04-03 00:43:04 UTC
Please remove the "max log size = 50". This rotates away anything useful.

Thanks,

Volker
Comment 4 Helmut Ennsbrunner 2009-04-03 14:43:21 UTC
Created attachment 4053 [details]
Level 10 log file without log size limit

consider only date 2009.04.03!

I tried to create a folder and a file on the ntfs partion in the extended partion - error "read-only file system".
After that I created a new folder on the ntfs partion in the primary partion - no problem!

regards
Heli
Comment 5 raouf riahi 2009-04-29 08:14:10 UTC
I like to see the version of module NTFS-3G because this module can to mount the partion NTFS in write and read
Comment 6 Helmut Ennsbrunner 2009-04-29 14:30:21 UTC
(In reply to comment #5)
> I like to see the version of module NTFS-3G because this module can to mount
> the partion NTFS in write and read
> 

How can I figure out the version of the NTFS-3G module? In fact I could not find any package with this name on my system. Additionally I had a look on ntfs-3g.org - I found the following line

/dev/sda1 /mnt/windows ntfs-3g defaults 0 0

that should be entered in fstab - in my case there is only "ntfs" instead of "ntfs-3g". 
Comment 7 Volker Lendecke 2009-05-13 04:34:00 UTC
Message from the log file:

[2009/04/03 21:27:51,  3] smbd/open.c:open_file(254)
  Permission denied opening new file

That's clearly something coming from the kernel. I'm closing this as invalid, I'm 100% certain this is a ntfs on linux problem. Please re-open if you can reproduce this on ext3.

Thanks,

Volker