Bug 6224 - nmbd waits 5 minutes at startup before checking if it needs to run elections
nmbd waits 5 minutes at startup before checking if it needs to run elections
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Nmbd
3.2.8
Other Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 14:16 UTC by Simo Sorce
Modified: 2009-03-26 15:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simo Sorce 2009-03-26 14:16:44 UTC
Found out that if you start nmbd with a workgroup where you are the only member. Elections are not run immediately and nmbd waits 5 minutes before becoming the local master.

After analysis with Jeremy we found out that this is caused by a bogus assignment in check_master_browser_exists()
Comment 1 Simo Sorce 2009-03-26 15:20:43 UTC
857c2e4407a0f4fcee721372ffed5366bc3051f9 fixed it
Thanks Jeremy, now it takes 15 seconds to become master browser from startup if no other machine exist in the same workgroup