Bug 6214 - Feature request: Dynamic configuration and shares
Feature request: Dynamic configuration and shares
Status: RESOLVED DUPLICATE of bug 7375
Product: Samba 4.0
Classification: Unclassified
Component: Tools
unspecified
Other Linux
: P3 enhancement
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 07:02 UTC by Matthieu Patou
Modified: 2011-03-05 22:41 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2009-03-25 07:02:32 UTC
There is no way with samba4 to force samba4 to reload the configuration so in order to add a share samba must restarted everytime.
Comment 1 Matthias Dieter Wallnöfer 2009-06-12 15:04:37 UTC
Yeah, in SAMBA 3 we have working the addition of shares dynamically during the server runtime (through RPC calls and registry backend). Sometime, we should also have something like this in SAMBA 4, I agree.
Mark as "Feature request".
Comment 2 Matthias Dieter Wallnöfer 2011-03-05 22:41:04 UTC
Let us mark this as duplicate of 7375 since the feature you describe is to be implemented by "smb.conf" reloading.

*** This bug has been marked as a duplicate of bug 7375 ***