Bug 6193 - "net rpc vampire" ends with a NT_STATUS_SYNCHRONIZATION_REQUIRED error
"net rpc vampire" ends with a NT_STATUS_SYNCHRONIZATION_REQUIRED error
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: User & Group Accounts
3.3.2
x64 Linux
: P3 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 05:02 UTC by Fabio Muzzi Frabetti
Modified: 2009-03-30 13:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Muzzi Frabetti 2009-03-17 05:02:14 UTC
I am trying to migrate a NT4 PDC to Samba. 

At the first try, I have used samba 3.2.5, which seemed to complete the
vampire process but then I have found that there is a bug that prevents
password from being migrated properly (and in fact passwords were not
migrated properly).

Then, I have removed the Linux server from the NT domain, deleted all
TDB files, installed and compiled Samba 3.3.2, rejoined the
domain, and now the vampire command only migrates some machine and users accounts (exactly 127 of them) and then dies with an error:


Fetching (to passdb) DOMAIN database
[2009/03/16 23:45:28,  0] passdb/pdb_tdb.c:tdb_update_samacct_only(527)
Failed to fetch DOMAIN database: NT_STATUS_SYNCHRONIZATION_REQUIRED


I have seen that when I delete the linux server from the NT domain
(using the server manager in NT) it still shows up in server manager,
even if it says that it is in fact deleted, and will disappear at the
next refresh (the next refresh of what?), it never disappears.

Now, is it because of this that I get this error? Maybe the PDC thinks
that he has to synchronize something to a BDC that has been removed from
the domain?

Or is there something wrong in the migration code that makes it stop working at exactly 127 accounts?


I have checked the event log on the NT PDC, and sometimes it says "The full syncronization request from LINUXSRV1 completed successfully. 131 objects have been returned to the caller" (even if I get only 127 of them on the Samba server, and also there are 188 users and about the same number of machine accounts on the NT PDC) and sometimes it reports an error that has no description, it says "The full syncronization request from LINUXSRV1 failed with the following error:" The error data reports 34 01 00 C0.
Comment 1 Guenther Deschner 2009-03-25 10:23:25 UTC
Ok, should be fixed with:

http://git.samba.org/?p=samba.git;a=commitdiff;h=efa7f6bff9bec89214dab368ff5efc61fa1cc212

Thanks for the report!
Comment 2 Fabio Muzzi Frabetti 2009-03-25 10:54:32 UTC
Thanks for the patch. Could you please tell me if this problem can actually cause data corruption on the NT PDC that I was trying to vampire? Because after the failed attempt at transferring the DC, I have found that I cannot add machines to the domain anymore, and that I seem to have  some sort of "ghost" BDC (the Samba machine) that cannot be deleted from the domain.

Comment 3 Fabio Muzzi Frabetti 2009-03-30 13:01:18 UTC
I can confirm that the patch worked properly, or at least it seems so, since I have moved 188 users and 324 computers and it seems all right!

Thanks a lot.