Bug 6186 - map readonly does not work.
map readonly does not work.
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: File services
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
: 4325 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 12:55 UTC by Jeremy Allison
Modified: 2009-07-01 09:05 UTC (History)
3 users (show)

See Also:


Attachments
Patch for 3.3.2. (1.59 KB, patch)
2009-03-12 12:56 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Allison 2009-03-12 12:55:34 UTC
Mapping DOS attribute bits to UNIX permission bits is broken in 3.3.0 - 3.3.2. This is due to open for FILE_WRITE_ATTRIBUTES not being allowed when a file is read-only (UNIX permissions).

A work around is to set:

     ea support = yes
     store dos attributes = yes
     map system = no
     map archive = no
     map readonly = no

on a system with extended attributes so the DOS attributes are stored there.

Jeremy.
Comment 1 Jeremy Allison 2009-03-12 12:56:43 UTC
Created attachment 3991 [details]
Patch for 3.3.2.

This fixes the bug.
Jeremy.
Comment 2 Jeremy Allison 2009-03-18 18:31:53 UTC
*** Bug 4325 has been marked as a duplicate of this bug. ***
Comment 3 Debian samba package maintainers (PUBLIC MAILING LIST) 2009-03-29 07:32:17 UTC
Will this be included in 3.3.3?

Someone reported the issue in Debian as http://bugs.debian.org/521225, marking it release critical, which blocks the package to enter Debian testing. So, I'd welcome seeing this fixed in the next upstream release, of course.

--
Christian Perrier
Comment 4 Volker Lendecke 2009-03-29 09:21:58 UTC
That patch entered the v3-3-stable with

http://git.samba.org/?p=samba.git;a=commit;h=8202c42e

So yes, it will be in 3.3.3.

Volker

Comment 5 Guenther Deschner 2009-07-01 09:05:24 UTC
Fix has been published. Closing bug report.

Please reopen if still an issue.