Bug 6181 - Samba crashes after connecting to share
Samba crashes after connecting to share
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: User & Group Accounts
3.3.1
x86 Linux
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 04:09 UTC by Robert Wroblewski
Modified: 2009-05-15 08:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Wroblewski 2009-03-11 04:09:52 UTC
Samba crashes after connecting XP (Pro) client to share.

Mar 11 07:17:12 cood smbd_audit[9941]: connect to service wspolny by user psk1
Mar 11 07:17:12 cood smbd_audit[9941]: [2009/03/11 07:17:12,  0] lib/fault.c:fault_report(41)
Mar 11 07:17:12 cood smbd_audit[9941]:   INTERNAL ERROR: Signal 11 in pid 9941 (3.3.1)
Mar 11 07:17:12 cood smbd_audit[9941]:   Please read the Trouble-Shooting section of the Samba3-HOWTO
Mar 11 07:17:12 cood smbd_audit[9941]: [2009/03/11 07:17:12,  0] lib/fault.c:fault_report(43)
Mar 11 07:17:12 cood smbd_audit[9941]:
Mar 11 07:17:12 cood smbd_audit[9941]:   From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
Mar 11 07:17:12 cood smbd_audit[9941]: [2009/03/11 07:17:12,  0] lib/fault.c:fault_report(44)
Mar 11 07:17:12 cood smbd_audit[9941]:   ===============================================================
Mar 11 07:17:12 cood smbd_audit[9941]: [2009/03/11 07:17:12,  0] lib/util.c:smb_panic(1673)
Mar 11 07:17:12 cood smbd_audit[9941]:   PANIC (pid 9941): internal error
Mar 11 07:17:12 cood smbd_audit[9941]: [2009/03/11 07:17:12,  0] lib/util.c:log_stack_trace(1777)
Mar 11 07:17:12 cood smbd_audit[9941]:   BACKTRACE: 12 stack frames:
Mar 11 07:17:12 cood smbd_audit[9941]:    #0 /usr/sbin/smbd(log_stack_trace+0x2d) [0xb7dc5ca5]
Mar 11 07:17:12 cood smbd_audit[9941]:    #1 /usr/sbin/smbd(smb_panic+0x7c) [0xb7dc5dfe]
Mar 11 07:17:12 cood smbd_audit[9941]:    #2 /usr/sbin/smbd [0xb7db097b]
Mar 11 07:17:12 cood smbd_audit[9941]:    #3 [0xb7ade400]
Mar 11 07:17:12 cood smbd_audit[9941]:    #4 /lib/libc.so.6(__vasprintf_chk+0xd9) [0xb7877b75]
Mar 11 07:17:12 cood smbd_audit[9941]:    #5 /usr/sbin/smbd [0xb7be7ac6]
Mar 11 07:17:12 cood smbd_audit[9941]:    #6 /usr/sbin/smbd(make_connection+0x732) [0xb7be8291]
Mar 11 07:17:12 cood smbd_audit[9941]:    #7 /usr/sbin/smbd(reply_tcon_and_X+0x3e6) [0xb7ba3583]
Mar 11 07:17:12 cood smbd_audit[9941]:    #8 /usr/sbin/smbd [0xb7be2351]
Mar 11 07:17:12 cood smbd_audit[9941]:    #9 /usr/sbin/smbd(smbd_process+0xef4) [0xb7be4310]
Mar 11 07:17:12 cood smbd_audit[9941]:    #10 /usr/sbin/smbd(main+0x112a) [0xb802e38f]
Mar 11 07:17:12 cood smbd_audit[9941]:    #11 /lib/libc.so.6(__libc_start_main+0xee) [0xb77aa6ee]
Mar 11 07:17:12 cood smbd_audit[9941]: [2009/03/11 07:17:12,  0] lib/fault.c:dump_core(218)
Mar 11 07:17:12 cood smbd_audit[9941]:   Can not dump core: corepath not set up

Share definition:

[wspolny]
    comment = Wspolny katalog sieciowy
    path = /home/services/samba/wspolny
    public = no
    writable = no
    write list = @users
    valid users = @users
    create mask = 0660
    available = yes
    browseable = yes
    guest only = no
    preexec close = no
    root preexec close = no
    directory mask = 0770
    inherit permissions = no
    hide dot files = yes
    fake oplocks = yes
    oplocks = True
    level2 oplocks = True
    veto oplock files =  *.DBF *.dbf
    vfs objects = audit recycle readonly readahead
    recycle:repository = .%U
    recycle:keeptree = True
    recycle:versions = True
    recycle:touch = True
    recycle:exclude = *.tmp *.o *.obj ~$* *.ba0
    recycle:exclude_dir = /tmp  /temp /cache

The same share works ok on Samba 3.3.0.
Comment 1 Jeremy Allison 2009-03-11 11:59:12 UTC
Can you compile with debug symbols (-g), then add the following to the [global]
section of your smb.conf:

panic action = "/bin/sleep 99999"

then reproduce the crash. You'll get a sleep process, whose parent will be the
crashed smbd. Attach to the crashed smbd with gdb, and type "bt" to get a full
backtrace (which should include line numbers).

Jeremy.
Comment 2 Karolin Seeger 2009-05-03 02:32:35 UTC
I cannot reproduce that with Samba 3.3.4.
Is that still an issue?
Comment 3 Karolin Seeger 2009-05-15 08:43:07 UTC
Closing out bug report.
Please er-open if it's still an issue.

Thanks for reporting!