Bug 6078 - admin users doesn't work as in 3.0.33
admin users doesn't work as in 3.0.33
Status: RESOLVED DUPLICATE of bug 6082
Product: Samba 3.3
Classification: Unclassified
Component: File services
3.3.0
x86 Windows XP
: P3 major
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 07:33 UTC by Sven Strickroth
Modified: 2009-02-02 17:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Strickroth 2009-02-01 07:33:18 UTC
In smb.conf I have:
[global]
...
admin users = @"DOMAIN\Domain Admins"
...

When I access a root owned share which a user which is in the "Domain Admins" group I can read/list all files from WXP-client.
The directory is 0700. Creating files work too, but if I try to delete a file or want to rename it, I get an access denied error-message.
Comment 1 Jeremy Allison 2009-02-02 12:21:03 UTC
There is a problem with deleting and renaming files in 3.3.0 with allowed users being reported as having no permissions. I'm working on this and should be able to attach a patch to this bug for the problem today.
Jeremy.
Comment 2 Jeremy Allison 2009-02-02 17:01:53 UTC
Consolidating ACL bug reports with 3.3.0 into one.
Jeremy.


*** This bug has been marked as a duplicate of 6082 ***