Bug 6074 - 3.3.0 doesn't fetch domain-users
3.3.0 doesn't fetch domain-users
Status: RESOLVED DUPLICATE of bug 5973
Product: Samba 3.3
Classification: Unclassified
Component: Winbind
3.3.0
All Linux
: P3 major
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 04:02 UTC by Christina Jagodics (550 #5.1.0 Address rejected)
Modified: 2009-02-09 07:53 UTC (History)
1 user (show)

See Also:


Attachments
smb.conf file used (1.05 KB, application/octet-stream)
2009-01-30 10:18 UTC, Christina Jagodics (550 #5.1.0 Address rejected)
no flags Details
nsswitch.conf used with samba 3.3.0 (488 bytes, application/octet-stream)
2009-02-03 09:35 UTC, Christina Jagodics (550 #5.1.0 Address rejected)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christina Jagodics (550 #5.1.0 Address rejected) 2009-01-29 04:02:44 UTC
I've no idea what's going wrong but somehow winbind doesn't seem to be able to fetch users from *any* domain. 
Joining my workstation to my domain is not a problem and also wbinfo works quite fine.
But when trying to fetch domain-user information typing 'getent passwd' I only get my local user-accounts listed.

I've already posted a more detailed description of the problem at bug-report #5973 but so far I've received no answer to that. 

Could anyone please give a short statement / update about what's being done about this? - Just to let people know you're on it.
Feeling pretty left alone with a problem that no one seems to care about.

Thanks.
Comment 1 Karolin Seeger 2009-01-30 01:22:58 UTC
Is it exactly the same problem as described in #5973?
Do you use the idmap_adex backend as well?
If not, please attach your smb.conf settings.
Comment 2 Michael Adam 2009-01-30 07:56:42 UTC
Does only "getent passwd" fail to give domain users?
"id domain\\user" works? "getent passwd domain\\user" works?

Listing domain users with "getent passwd" only works
when you have set "winbind enum users = yes" in smb.conf.
Correspondingly with "winbind enum groups = yes" for "getent group".

They both default to "no".

Cheers - Michael
Comment 3 Christina Jagodics (550 #5.1.0 Address rejected) 2009-01-30 10:17:41 UTC
Hi Karolin and Michael,

thanks a lot for responding.
Yes, the problem described in bugreport 5973 is exactly the one I have and yes, I do use the adex-backend. I will upload my smb.conf-file anyway, maybe there really is something wrong with it - but then: why did the exact same configuration work perfectly with 3.3.0rc1? - this is what I don't understand.

Michael, not only 'getent passwd' doesn't work but 'getent passwd domain\\user' and 'id domain\\user' as well.
The only thing that seems to work is 'wbinfo'. I just don't know what else I could try - I even joined my workstation to different domains - with the same result.

Comment 4 Christina Jagodics (550 #5.1.0 Address rejected) 2009-01-30 10:18:57 UTC
Created attachment 3898 [details]
smb.conf file used
Comment 5 John H Terpstra 2009-02-03 09:27:31 UTC
(In reply to comment #3)
> Hi Karolin and Michael,
> 
> thanks a lot for responding.
> Yes, the problem described in bugreport 5973 is exactly the one I have and yes,
> I do use the adex-backend. I will upload my smb.conf-file anyway, maybe there
> really is something wrong with it - but then: why did the exact same
> configuration work perfectly with 3.3.0rc1? - this is what I don't understand.
> 
> Michael, not only 'getent passwd' doesn't work but 'getent passwd domain\\user'
> and 'id domain\\user' as well.
> The only thing that seems to work is 'wbinfo'. I just don't know what else I
> could try - I even joined my workstation to different domains - with the same
> result.
> 

Please post your /etc/nsswitch.conf file. Thx.

- John T.
Comment 6 Christina Jagodics (550 #5.1.0 Address rejected) 2009-02-03 09:35:26 UTC
Created attachment 3910 [details]
nsswitch.conf used with samba 3.3.0

hi,

just uploaded the nsswitch.conf file we've used with 3.3.0rc1 as well as 3.3.0.

If you need anything else just ask.


Greetings
Christina.
Comment 7 Michael Adam 2009-02-03 09:48:10 UTC
hmm, if this is exactly the same as bug #5973, we should resolve this as duplicate.
Comment 8 Christina Jagodics (550 #5.1.0 Address rejected) 2009-02-03 09:51:20 UTC
no problem - would be easier to manage anyway.
Comment 9 Christina Jagodics (550 #5.1.0 Address rejected) 2009-02-03 11:41:40 UTC

*** This bug has been marked as a duplicate of 5973 ***
Comment 10 Christina Jagodics (550 #5.1.0 Address rejected) 2009-02-09 07:53:38 UTC
> 
> Please post your /etc/nsswitch.conf file. Thx.
> 
> - John T.
> (In reply to comment #9)
> 

John, 

did you make any progress with the problem described here?
If so, please keep us apprised. Again - if you need more information, just ask for them.

Thanks.
Christina.