Bug 6024 - swat disagrees with smbstatus as to share mode with share modes = No set in samba
swat disagrees with smbstatus as to share mode with share modes = No set in s...
Status: RESOLVED WONTFIX
Product: Samba 3.3
Classification: Unclassified
Component: SWAT
3.3.0rc2
Other Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
http://bugs.debian.org/511276
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 01:33 UTC by Debian samba package maintainers (PUBLIC MAILING LIST)
Modified: 2009-05-19 04:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Debian samba package maintainers (PUBLIC MAILING LIST) 2009-01-12 01:33:12 UTC
From our user:

I am running a samba share with share modes = No.  Swat reports open files as DENY_DOS on the status page, while smbstatus reports the 
same connections as DENY_NONE.  This discrepancy caused significant loss of time troubleshooting why changing samba options did not appear 
to take, when in fact swat was the one not reflecting the changes.  

Times of file opens and closes appear OK, just the sharing field appears wrong.
Comment 1 Jeremy Allison 2009-01-12 18:21:14 UTC
Running Samba with share modes = No is not really a supported configuration (in fact it's never tested in any of our trees). In the 3.3 codebase it is only looked at in one place. The real solution to this is "don't do that".
Jeremy.
Comment 2 Karolin Seeger 2009-05-19 04:43:01 UTC
Closing out bug report.

Thanks for reporting!