Bug 6023 - "recurse" changes "ls" behaviour in smbclient while not advertized
"recurse" changes "ls" behaviour in smbclient while not advertized
Status: RESOLVED DUPLICATE of bug 6021
Product: Samba 3.3
Classification: Unclassified
Component: Client tools
3.3.0rc2
Other Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
http://bugs.debian.org/509258
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 01:27 UTC by Debian samba package maintainers (PUBLIC MAILING LIST)
Modified: 2009-01-12 02:02 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Debian samba package maintainers (PUBLIC MAILING LIST) 2009-01-12 01:27:28 UTC
"recurse" is theoretically meant to change the behaviour of mput and mget commands in smbclient. However, it apparently also changes the behaviour of "ls" and gives strange results:

Here's the content of a share on my machine:
root@mykerinos:/var/tmp/samba-test> ls -lR
.:
total 4
-rw-rwx---+ 1 root bikinibottom  0 déc 29 13:00 bar
-rw-------  1 root spongebob     0 déc 29 13:00 foo
drwxrwsr-x  2 root bikinibottom 16 jan 12 07:58 titi
drwxrwsr-x  2 root bikinibottom 16 jan 12 07:58 toto

./titi:
total 4
-rw-rw-r-- 1 root bikinibottom 4 jan 12 07:58 foo

./toto:
total 4
-rw-rw-r-- 1 root bikinibottom 4 jan 12 07:58 foo


Accessing it with smbclient gives:
bubulle@mykerinos:~/travail/debian/rewrite/INTENT> smbclient //127.0.0.1/public
Enter bubulle's password:
Domain=[MYKERINOS] OS=[Unix] Server=[Samba 3.3.0rc2]
smb: \> ls
  .                                   D        0  Mon Jan 12 07:58:18 2009
  ..                                  D        0  Mon Jan 12 05:53:54 2009
  bar                                          0  Mon Dec 29 13:00:02 2008
  foo                                          0  Mon Dec 29 13:00:02 2008
  toto                                D        0  Mon Jan 12 07:58:22 2009
  titi                                D        0  Mon Jan 12 07:58:26 2009

                60675 blocks of size 32768. 26904 blocks available
smb: \> recurse
smb: \> ls
  .                                   D        0  Mon Jan 12 07:58:18 2009
  ..                                  D        0  Mon Jan 12 05:53:54 2009
  bar                                          0  Mon Dec 29 13:00:02 2008
  foo                                          0  Mon Dec 29 13:00:02 2008
  toto                                D        0  Mon Jan 12 07:58:22 2009
  titi                                D        0  Mon Jan 12 07:58:26 2009

(null)\toto

(null)\titi

                60675 blocks of size 32768. 26904 blocks available


As ones sees, "recurse" has some effect on "ls" while the result is not very interesting (one would expect the equivalent of "ls -R" or something.

And, anyway, this is not really documented:

smb: \> help recurse
HELP recurse:
        toggle directory recursion for mget and mput
Comment 1 Jeremy Allison 2009-01-12 02:02:36 UTC

*** This bug has been marked as a duplicate of 6021 ***