Bug 5998 - DFS links are vanished when "expand_msdfs" is set.
DFS links are vanished when "expand_msdfs" is set.
Status: RESOLVED DUPLICATE of bug 7081
Product: Samba 3.2
Classification: Unclassified
Component: File services
3.2.6
x86 Windows XP
: P3 minor
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 23:58 UTC by TAKAHASHI Motonobu
Modified: 2010-02-02 16:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TAKAHASHI Motonobu 2008-12-28 23:58:16 UTC
DFS links are vanished when "vfs object = expand_msdfs" i set.

To reproduce:

(1) set smb.conf like:

[global]
  host msdfs = yes

[dfstop]
  path = /some/where/
  msdfs root = yes

(2) create a DFS link and check to work correctly

(3) added a line to "dfstop" section like:

  vfs object = expand_msdfs

(4) all DFS links under that share is vanished. And logs:

-----
[2008/12/29 14:50:29,  3] smbd/msdfs.c:dfs_redirect(686)
  dfs_redirect: Not redirecting \samba32a\dfsroot\*.
[2008/12/29 14:50:29,  3] smbd/msdfs.c:dfs_redirect(697)
  dfs_redirect: Path \samba32a\dfsroot\* converted to non-dfs path *
[2008/12/29 14:50:29,  3] smbd/dir.c:dptr_create(520)
  creating new dirptr 256 for path ./, expect_close = 1
[2008/12/29 14:50:29,  3] locking/locking.c:fetch_share_mode_unlocked(857)
  fill_share_mode_lock failed
[2008/12/29 14:50:29,  3] locking/locking.c:fetch_share_mode_unlocked(857)
  fill_share_mode_lock failed
[2008/12/29 14:50:29,  0] lib/util_str.c:safe_strcpy_fn(709)
  ERROR: string overflow by 1 (6 - 5) in safe_strcpy [msdfs:samba32c\archives$]
[2008/12/29 14:50:29,  0] lib/util_str.c:safe_strcpy_fn(709)
  ERROR: string overflow by 1 (6 - 5) in safe_strcpy [msdfs:samba32c\notexist,sa
mba32b\archives$]
-----

* Windows XP client still can access to the DFS target via full UNC like "\\samba\dfstop\dfstarget", but Vista cannot.
Comment 1 Jeremy Allison 2010-02-02 16:17:04 UTC

*** This bug has been marked as a duplicate of bug 7081 ***