Bug 5997 - "net rpc shutdown" doesn't work anymore since 3.2.0
"net rpc shutdown" doesn't work anymore since 3.2.0
Status: RESOLVED DUPLICATE of bug 5898
Product: Samba 3.2
Classification: Unclassified
Component: Client tools
3.2.5
Other Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
http://bugs.debian.org/496786
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-26 08:20 UTC by Debian samba package maintainers (PUBLIC MAILING LIST)
Modified: 2008-12-27 00:23 UTC (History)
0 users

See Also:


Attachments
Level 10 debug log of a succeeded session with samba 3.0.24 (8.79 KB, application/octet-stream)
2008-12-26 08:21 UTC, Debian samba package maintainers (PUBLIC MAILING LIST)
no flags Details
Level 10 debug log of a failed session with samba 3.2.5 (10.01 KB, application/octet-stream)
2008-12-26 08:22 UTC, Debian samba package maintainers (PUBLIC MAILING LIST)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Debian samba package maintainers (PUBLIC MAILING LIST) 2008-12-26 08:20:46 UTC
From our Debian users....I can also reproduce that bug.

The "net rpc shutdown" command, which makes easy to reboot several machines through scripts, does not longer work since 3.2.0.

I'll attach level 10 logs of two attempts:
One that fails from a machine running samba 3.2.5
One that succeeds from a machine running samba 3.0.24

Output when the command fails:
bubulle@mykerinos:~/tmp> net rpc shutdown  -r -S khephren -U MAISON\\bubulle
Enter MAISON\bubulle's password:

Shutdown of remote machine failed

result was: WERR_OK
Comment 1 Debian samba package maintainers (PUBLIC MAILING LIST) 2008-12-26 08:21:48 UTC
Created attachment 3830 [details]
Level 10 debug log of a succeeded session with samba 3.0.24
Comment 2 Debian samba package maintainers (PUBLIC MAILING LIST) 2008-12-26 08:22:32 UTC
Created attachment 3831 [details]
Level 10 debug log of a failed session with samba 3.2.5
Comment 3 Debian samba package maintainers (PUBLIC MAILING LIST) 2008-12-27 00:23:17 UTC
Thanks to one of our users, we found this is fixed in 3.2.6 (which we don't have in Debian) and 3.3.0

And I finally found this is a duplicate of #5898.

*** This bug has been marked as a duplicate of 5898 ***