Bug 5977 - --delay-updates --partial-dir
--delay-updates --partial-dir
Status: RESOLVED INVALID
Product: rsync
Classification: Unclassified
Component: core
3.0.4
x86 Windows XP
: P3 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 15:59 UTC by gb43254
Modified: 2009-01-23 12:57 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gb43254 2008-12-16 15:59:58 UTC
up.txt
CACN.ini
GameGuard/CACN.ini


c:\rc\rsync -rltzpP    --chmod=auog+rwx  --files-from=/cygdrive/c/rc/up.txt  --partial-dir=/cygdrive/d/temp --delay-updates test@222.218.45.7::test/泡泡堂/ /cygdrive/d/泡泡堂/

C:\rc>c:\rc\rsync -rltzpP    --chmod=auog+rwx  --files-from=/cygdrive/c/rc/up.tx
t  --partial-dir=/cygdrive/d/temp --delay-updates test@222.218.45.7::test/泡泡堂
/ /cygdrive/d/泡泡堂/
receiving file list ...
3 files to consider
CACN.ini
         402 100%  392.58kB/s    0:00:00 (xfer#1, to-check=2/3)
GameGuard/
GameGuard/CACN.ini
         416 100%    2.88kB/s    0:00:00 (xfer#2, to-check=0/3)
rsync: rename failed for "/cygdrive/d/泡泡堂/GameGuard/CACN.ini" (from /cygdrive
/d/temp/CACN.ini): No such file or directory (2)

sent 67 bytes  received 1011 bytes  196.00 bytes/sec
total size is 818  speedup is 0.76
rsync error: some files/attrs were not transferred (see previous errors) (code 2
3) at main.c(1506) [generator=3.0.4]
Comment 1 Matt McCutchen 2008-12-19 00:41:27 UTC
What makes you think this is a bug in rsync?  To me it looks more likely to be caused by Windows and/or Cygwin mishandling the special characters in the path.
Comment 2 Matt McCutchen 2009-01-23 12:57:50 UTC
There is no evidence that this is a bug in rsync.