Bug 5952 - Windows client mounting SMB only from one CTDB servers
Windows client mounting SMB only from one CTDB servers
Status: RESOLVED WORKSFORME
Product: Samba 3.2
Classification: Unclassified
Component: Clustering
3.2.3
x86 Linux
: P3 critical
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 14:33 UTC by Tim Clusters
Modified: 2009-01-07 12:48 UTC (History)
0 users

See Also:


Attachments
Network packets snoop at SMB port, log.smb and log.winbind (14.13 KB, text/plain)
2008-12-07 14:36 UTC, Tim Clusters
no flags Details
Initial node1 Winbind/SMB/CTDB log files after CTDB start (721.05 KB, text/plain)
2008-12-08 16:43 UTC, Tim Clusters
no flags Details
Initial node2 Winbind/SMB/CTDB log files after CTDB restart (237.22 KB, text/plain)
2008-12-08 16:44 UTC, Tim Clusters
no flags Details
node2 Winbind/SMB/CTDB log file after Windbind restart(only on node2) (514.13 KB, text/plain)
2008-12-08 16:45 UTC, Tim Clusters
no flags Details
SMB + CTDB configuration (4.26 KB, text/plain)
2008-12-08 16:46 UTC, Tim Clusters
no flags Details
CTDB Status and connectivity to SMB daemon (29.74 KB, text/plain)
2008-12-09 15:50 UTC, Tim Clusters
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Clusters 2008-12-07 14:33:21 UTC
Hi,

This bug is related to #5941. So the smb.conf (added unique NETBIOS NAME), CTDB settings and software versions are identical to being described in #5941.

Assigning CTDB SMB servers with unique NetBIOS Id resolved #5941. However, now the Windows client can mount only from one CTDB-SMB servers. 

When you try to connect to another server you get the following error:
###

The mapped networked drive could not be created because the following error has occurred:

“The specified network name is no longer available”

##

Iam unable to use “NetBIOS name” as even though it is listed in network neighbourhood, it does not list the shares when you click. So I use the \\IP-Address\global-share to mount SMB share. We have a round-robin name setup for NAS-head (ctdb-head), but it works only if you happen to chose the right IP address that can be SMB mounted.

When we restart “Winbind” on the server from which Windows client would not mount, it works! But after that when you try to mount from the other server, it fails. So, at a given instance Windows client can only mount from single SMB server in CTDB cluster. 

Looking at the “SMB network packets” + SMB + Winbind + CTDB log, I do not find any major error. One thing I see is that, SMB server gets the user-id (TESTDOMAIN\username) when they try to remote mount but after that “client connection seems to shutdown” unless you restart Winbind on the connecting SMB server.  I wonder if the client socket parameters/ user credentials gets synced up when you restart Winbind?

Please find all the information you asked for attached. I would like Windows clients to mount from multiple SMB servers controlled by CTDB. Thoughts/advice to resolve this would be appreciated.

Thanks in Advance,
-Tim
Comment 1 Tim Clusters 2008-12-07 14:36:18 UTC
Created attachment 3786 [details]
Network packets snoop at SMB port, log.smb and log.winbind
Comment 2 Volker Lendecke 2008-12-07 14:47:16 UTC
What we need is a full debug level 10 log of both winbind (all log.wb* files) and smbd, along with your smb.conf

Volker
Comment 3 Tim Clusters 2008-12-08 16:43:14 UTC
Created attachment 3791 [details]
Initial node1 Winbind/SMB/CTDB log files after CTDB start

md5sum log.node1.initial.tgz
a37398551c253b88cab4dbd9b850bfa4  log.node1.initial.tgz
Comment 4 Tim Clusters 2008-12-08 16:44:21 UTC
Created attachment 3792 [details]
Initial node2 Winbind/SMB/CTDB log files after CTDB restart

md5sum log.node2.initial.tgz
7a79b162011a6542707afc4def80e733  log.node2.initial.tgz
Comment 5 Tim Clusters 2008-12-08 16:45:39 UTC
Created attachment 3793 [details]
node2 Winbind/SMB/CTDB log file after Windbind restart(only on node2)

 md5sum log.node2.after.winbind.restart.tgz
3f402245f06e28de39c3114dbe8f4dc7  log.node2.after.winbind.restart.tgz
Comment 6 Tim Clusters 2008-12-08 16:46:18 UTC
Created attachment 3794 [details]
SMB + CTDB configuration

md5sum configuration.tgz
eee850667707cf29092a130c03498e13  configuration.tgz
Comment 7 Tim Clusters 2008-12-08 16:51:28 UTC
Hi,

I have attached the Winbind + SMB + CTDB log files with debug level of 10 + necessary CTDB/SMB configuration files. 

Windows node were able to mount initially only from node1(192.168.97.5). After Winbind restart on node2(192.168.97.6), Windows node were able to mount from node2 but failed to mount from node1. 

Please let me know if you require additional information.

Best Regards,
-Tim  
Comment 8 Tim Clusters 2008-12-08 19:09:22 UTC
Hi,

Perusing though the log files, Iam wondering if the issue is due to insufficient UID/GID range and/or winbind unable to properly extract UID from SID. I have specified SMB to use Active Directory RID mapping scheme for 
SID --> UID/GID Mapping.

I see the following errors in log.smb on both the nodes at the same instance, but still somehow one node is able to map SID to UID/GID as we can mount from Windows clients.

---
[2008/12/08 13:46:55,  3] lib/privileges.c:get_privileges(63)
get_privileges: No privileges assigned to SID [S-1-0-0]
get_privileges_for_sids: sid = S-1-1-0
get_privileges: No privileges assigned to SID [S-1-5-32-546]
get_privileges: No privileges assigned to SID [S-1-22-2-99]
winbind failed to find a gid for sid S-1-1-0
Could not convert SID S-1-1-0 to gid, ignoring it
winbind failed to find a gid for sid S-1-5-2
Could not convert SID S-1-5-2 to gid, ignoring it
winbind failed to find a gid for sid S-1-5-32-546
Could not convert SID S-1-5-32-546 to gid, ignoring it
--

--
[2008/12/08 13:46:55,  3] groupdb/mapping.c:pdb_create_builtin_alias(786)
pdb_create_builtin_alias: Could not get a gid out of winbind
WARNING: Failed to create BUILTIN\Users group! Can Winbind allocate gids?
--

Please accept my apologies if the above has nothing to do with the issue and for generating noise.

Thanks,
-Tim
Comment 9 Tim Clusters 2008-12-09 15:50:23 UTC
Created attachment 3806 [details]
CTDB Status and connectivity to SMB daemon


Output of:

- ctdb status
- ctdb ping -n all
- smbcontrol smbd ping
- ctdb listvars
Comment 10 Tim Clusters 2009-01-07 12:48:54 UTC
Migrating to Windows 2003 AD + IDMAP Backend=AD seems to resolve this.