Bug 5937 - filenames with "*" char hide other files
filenames with "*" char hide other files
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Client tools
3.2.5
x86 Linux
: P3 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 06:31 UTC by Omar
Modified: 2008-12-04 17:40 UTC (History)
1 user (show)

See Also:


Attachments
Patch for all branches. (647 bytes, patch)
2008-12-04 17:37 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Omar 2008-12-04 06:31:06 UTC
Steps to Reproduce:

1) mount using cifs the target share
2) cd to the target share directory
3) mkdir dir
4) cd dir
5) touch a b c
6) touch \*

Expected Results:

7) ls
* a b c

Actual Results:

7b) ls
* a b

Reproducible: always

Notes: This problem was observed in Fedora Core 8 and 9, but not in Fedora Core 6 (samba-3.0.24)
Comment 1 Steve French 2008-12-04 13:52:36 UTC
I can reproduce this.  For directory contents: file1, file2, file3 and *   The client is requesting a findfirst level 514, which returns 4 entries ("." and ".." and "file1" and "*" but not returning file2 and file3) and marks "end of search" so the client does not continue
Comment 2 Steve French 2008-12-04 13:53:15 UTC
(In reply to comment #1)
> I can reproduce this.  For directory contents: file1, file2, file3 and *   The
> client is requesting a findfirst level 514, which returns 4 entries ("." and
> ".." and "file1" and "*" but not returning file2 and file3) and marks "end of
> search" so the client does not continue
> 

so this looks like a server problem in the trans2 findfirst/findnext code
Comment 3 Jeremy Allison 2008-12-04 13:57:10 UTC
Not so fast, client boy :-). Can't reproduce on current samba-3-2-test git tree.
I see 4 files :

ls -l
total 4096
-rw-rw-r-- 1 jra eng 0 Dec  4 11:54 *
-rw-rw-r-- 1 jra eng 0 Dec  4 11:54 a
-rw-rw-r-- 1 jra eng 0 Dec  4 11:54 b
-rw-rw-r-- 1 jra eng 0 Dec  4 11:54 c
Comment 4 Jeremy Allison 2008-12-04 17:37:25 UTC
Created attachment 3780 [details]
Patch for all branches.

Checked into all git trees. Should be fixed now - thanks !
Jeremy.
Comment 5 Jeremy Allison 2008-12-04 17:40:02 UTC
Confirmed fixed by Stevef.
Jeremy.