Bug 5918 - "hosts allow" cause 6 seconds delay in SMB connexions
"hosts allow" cause 6 seconds delay in SMB connexions
Status: RESOLVED INVALID
Product: Samba 3.2
Classification: Unclassified
Component: Config Files
3.2.3
x64 Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-24 21:21 UTC by oxmosys
Modified: 2009-05-13 10:44 UTC (History)
0 users

See Also:


Attachments
smb.conf used to reproduce the bug. (11.98 KB, application/octet-stream)
2008-11-24 21:22 UTC, oxmosys
no flags Details
log.smbd (159.38 KB, application/octet-stream)
2008-11-25 14:37 UTC, oxmosys
no flags Details
log.zxz-desktop (140.32 KB, application/octet-stream)
2008-11-25 14:37 UTC, oxmosys
no flags Details
log.192.168.1.100 (36.34 KB, application/octet-stream)
2008-11-25 14:38 UTC, oxmosys
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description oxmosys 2008-11-24 21:21:21 UTC
When adding "hosts allow = 192.168.1." in [global] section of smb.conf, samba server takes 6 seconds before accepting the connexion from any host. I need to wait 6 seconds when typing smb://192.168.1.100/x in nautilus (or \\192.168.1.100\x in windows) before I'm asked for the username and password.

"hosts allow" is added in smb.conf when using gsambad 0.2.7 to choose which IP address can access the share.

Using samba 2:3.2.3-1ubuntu3 in ubuntu 8.10 :
Comment 1 oxmosys 2008-11-24 21:22:00 UTC
Created attachment 3763 [details]
smb.conf used to reproduce the bug.
Comment 2 oxmosys 2008-11-24 21:23:28 UTC
I want to add that this bug didn't happen with 3.0.28a-1ubuntu4.4 version of samba in ubuntu 8.04 with the same smb.conf file, so it looks like a regression.
Comment 3 Volker Lendecke 2008-11-25 00:30:11 UTC
Please upload a debug level 10 log of smbd showing this timeout
Comment 4 oxmosys 2008-11-25 14:37:07 UTC
Created attachment 3765 [details]
log.smbd
Comment 5 oxmosys 2008-11-25 14:37:58 UTC
Created attachment 3766 [details]
log.zxz-desktop
Comment 6 oxmosys 2008-11-25 14:38:29 UTC
Created attachment 3767 [details]
log.192.168.1.100
Comment 7 oxmosys 2008-11-25 14:39:23 UTC
I attached smbd.log in level 10 mode with two other logs that appeared when I reproduce the timeout bug.
Comment 8 Volker Lendecke 2008-11-25 15:04:26 UTC
Ok, nothing obvious. Next idea would be that we do something IPv6y with DNS that takes longer than the IPv4 only stuff in your 3.0 setup did. You might want to look at network sniffs.

Volker
Comment 9 oxmosys 2008-11-25 21:45:09 UTC
Mmh, I'm not sure that I would have necessary skill to do this, unless there is some tutorial to help me giving you the necessary information. 

I also found that changing "hosts allow = 192.168.1." to "hosts allow = 192.168.1.100" removes the timeout problem. The same apply if you use another IP, 127.0.0. and 127.0.0.1 for localhost, as an example. I tested this on one machine and one virtual machine.
Comment 10 Karolin Seeger 2009-05-13 04:26:20 UTC
Volker, can we close this one?
Comment 11 Volker Lendecke 2009-05-13 04:29:54 UTC
oxmosys, information on how to create network sniffs can be found under

http://wiki.samba.org/index.php/Capture_Packets

We'll wait a couple of days for sniffs, and then close the report bug.

Volker
Comment 12 oxmosys 2009-05-13 10:44:53 UTC
This bug can be closed, I'm not able to reproduce this bug anymore with samba 2:3.3.2-1ubuntu3, not even with my old router on which I reproduced the bug in the past.

Thanks!