Bug 5915 - winbindd core dump
winbindd core dump
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.32
x86 FreeBSD
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 5845 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-21 09:44 UTC by Alexander Druzhin
Modified: 2016-04-29 01:11 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Druzhin 2008-11-21 09:44:31 UTC
I am using samba fot NTLM authentication Squid users.
Samba compiled with active directory support.
Winbindd core dump several times a week at night-time (when no user activity).

log.winbindd
============
Assertion failed: (r != NULL), function ldap_parse_result, file error.c, line 272.
[2008/11/15 05:10:01, 0] lib/fault.c:fault_report(41)
  ===============================================================
[2008/11/15 05:10:01, 0] lib/fault.c:fault_report(42)
  INTERNAL ERROR: Signal 6 in pid 637 (3.0.32)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2008/11/15 05:10:01, 0] lib/fault.c:fault_report(44)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2008/11/15 05:10:01, 0] lib/fault.c:fault_report(45)
  ===============================================================
[2008/11/15 05:10:01, 0] lib/util.c:smb_panic(1633)
  PANIC (pid 637): internal error
[2008/11/15 05:10:01, 0] lib/util.c:log_stack_trace(1737)
  BACKTRACE: 19 stack frames:
   #0 0xd32bd <smb_panic+93> at /usr/local/sbin/winbindd
   #1 0xbd686 <dump_core_setup+1014> at /usr/local/sbin/winbindd
   #2 0xbfbfffb4
   #3 0x20691f1a <abort+106> at /lib/libc.so.7
   #4 0x206793a6 <__assert+86> at /lib/libc.so.7
   #5 0x2058243f <ldap_parse_result+863> at /usr/local/lib/libldap-2.4.so.3
   #6 0x1db5ac <ads_clear_service_principal_names+2172> at /usr/local/sbin/winbindd
   #7 0x1db92f <ads_do_search_all_args+111> at /usr/local/sbin/winbindd
   #8 0x1e4c39 <ads_atype_map+361> at /usr/local/sbin/winbindd
   #9 0x1e51ba <ads_do_search_retry+58> at /usr/local/sbin/winbindd
   #10 0x1e5320 <ads_search_retry_dn+80> at /usr/local/sbin/winbindd
   #11 0x663da <msrpc_name_to_sid+6394> at /usr/local/sbin/winbindd
   #12 0x4e0cc <cache_name2sid+4188> at /usr/local/sbin/winbindd
   #13 0x45965 <winbindd_setgrent+1269> at /usr/local/sbin/winbindd
   #14 0x47690 <winbindd_getgrent+2608> at /usr/local/sbin/winbindd
   #15 0x3fd80 <request_finished_cont+896> at /usr/local/sbin/winbindd
   #16 0x40379 <winbind_check_sighup+521> at /usr/local/sbin/winbindd
   #17 0x40df4 <main+2420> at /usr/local/sbin/winbindd
   #18 0x3ef99 <_start+137> at /usr/local/sbin/winbindd
[2008/11/15 05:10:01, 0] lib/fault.c:dump_core(181)
  dumping core in /var/log/samba/cores/winbindd

smb.conf
========
   workgroup = MY_DOMAIN
   security = ads
   hosts allow = 192.168. 127.
;   load printers = yes
   realm = LOCAL
   interfaces = bce0
   display charset = koi8-r
   unix charset = koi8-r   
   dos charset = cp866     
   winbind uid = 10000-20000       
   winbind gid = 10000-20000       
   winbind use default domain = yes
   winbind enum users=yes 
   winbind enum groups=yes
Comment 1 Matthias Dieter Wallnöfer 2009-07-27 15:52:06 UTC
*** Bug 5845 has been marked as a duplicate of this bug. ***
Comment 2 Björn Jacke 2016-04-29 01:11:35 UTC
sorry for no feed ack here. if you see issues with a recent supported samba version, please file a new report for that. this core dump is probably fixed already.