Bug 5893 - the recycle directory does not exclude itself from itself
the recycle directory does not exclude itself from itself
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: VFS Modules
unspecified
x86 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 14:10 UTC by Jan Rome
Modified: 2009-05-19 06:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Rome 2008-11-13 14:10:46 UTC
using the vfs object recycle, whenever an active user authenticated into a samba share deletes files from the repository folder, the files instantly reappear with a new name (an additional prefix of Copy #1 infront of the name).

Deleting the new file results in Copy #1 of Copy#1 of file... deleting that file makes Copy #1 of Copy #1 of Copy #1 of file etc.

It would be easy enough to exlcude_dir the repository folder itself, but that function is obviously broken.
Comment 1 Karolin Seeger 2009-05-19 06:26:26 UTC
Cannot reproduce using Samba 3.2.11.
Closing out bug report.

Please re-open if it's still an issue.