Bug 5870 - Cannot join pure Win2008 AD
Cannot join pure Win2008 AD
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: File services
3.2.4
x64 Linux
: P3 major
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 02:37 UTC by Roland Hebertinger
Modified: 2008-11-06 04:39 UTC (History)
0 users

See Also:


Attachments
Output of "net ads join -U Administrator -d 10" (197.14 KB, text/plain)
2008-11-04 02:39 UTC, Roland Hebertinger
no flags Details
Output of "tcpdump -w net-ads-join.dump -s 0" while trying to join the domain (94.65 KB, application/octet-stream)
2008-11-05 11:53 UTC, Roland Hebertinger
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Hebertinger 2008-11-04 02:37:51 UTC
With a fresh installed Samba 3.2.4 running on SLES 10 SP2 i'm not able to join a fresh AD runnig on Windows 2008 Server. The host-entry in the AD is created, but net ads join fails with "Failed to join domain: failed to set machine spn: Can't contact LDAP server"
Comment 1 Roland Hebertinger 2008-11-04 02:39:29 UTC
Created attachment 3708 [details]
Output of "net ads join -U Administrator -d 10"

Output of "net ads join -U Administrator -d 10"
Comment 2 Guenther Deschner 2008-11-05 08:58:25 UTC
Looking into this
Comment 3 Guenther Deschner 2008-11-05 10:57:23 UTC
I cannot reproduce this, can you please provide a network trace of this failed join ?
Comment 4 Roland Hebertinger 2008-11-05 11:23:15 UTC
i also tried 3.2.3, which didn't work out either. The dump will follow in a few minutes.
Comment 5 Roland Hebertinger 2008-11-05 11:53:45 UTC
Created attachment 3712 [details]
Output of "tcpdump -w net-ads-join.dump -s 0" while trying to join the domain
Comment 6 Guenther Deschner 2008-11-06 03:46:12 UTC
Ok, I checked with the openldap and samba maintainers at suse, and apparently there is an openldap update available that fixes these sudden dropdowns of LDAP connections. Can you try to update ldap and verify it is fixed?
Comment 7 Roland Hebertinger 2008-11-06 04:39:59 UTC
The latest available openldap2-client-Update solved the problem. Joining the domain works now.

Thanks a lot for your help!