Bug 586 - "configure: error: libldap is needed for LDAP support"
"configure: error: libldap is needed for LDAP support"
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
All Solaris
: P3 normal
: none
Assigned To: Tim Potter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-08 07:53 UTC by Josh Clingan
Modified: 2005-11-14 09:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Clingan 2003-10-08 07:53:16 UTC
When configuring with "--with-automount --with-ldap --with-ldapsam" I get this 
error - "configure: error: libldap is needed for LDAP support". It seems it is 
looking for the libldap.so.5 that comes bundled with Solaris 5.9. I have all 
the necessary files and the system authenticates fine using LDAP.
Comment 1 Gerald (Jerry) Carter 2003-10-09 07:52:07 UTC
Samba 3.0 requires the OpenLDAP libs.  We don't support the Sun 
libs currently.
Comment 2 Roust 2003-11-24 21:37:45 UTC
I have installed openldap-1.2.11 on Solaris 8, but I get this 
error - "configure: error: libldap is needed for LDAP support".
Comment 3 Gerald (Jerry) Carter 2003-12-07 22:52:45 UTC
you need openldap 2.x.  1.2 is too old.  Also make sure that you fix
your include paths and lib paths.  This is not Samba's bug.  Sorry.
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:30:15 UTC
database cleanup