Bug 5844 - smb donot return error for a file with extended attribute
smb donot return error for a file with extended attribute
Status: RESOLVED DUPLICATE of bug 5841
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.28
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 23:56 UTC by hargagan
Modified: 2008-10-23 00:12 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hargagan 2008-10-22 23:56:22 UTC
I am using 3.0.28 version of samba. 
I am having a problem where the smb doesn't return error in the smb_set_file_disposition_info(), when I am trying to delete a file on the NSS volume. The file has the delete inhibit attribute set. The error access denied is returned in the reply_close() path where it does unlink() on that file.

In this scenario, when I delete the file from the windows XP client, the file gets disappear untill refresh is done. So client doesn't get any error whatsoever for a file which was not deleted.
Comment 1 Volker Lendecke 2008-10-23 00:12:39 UTC

*** This bug has been marked as a duplicate of 5841 ***