Bug 5785 - smbclient -c 'archive 0; recurse; du' reports 0 bytes
smbclient -c 'archive 0; recurse; du' reports 0 bytes
Status: RESOLVED DUPLICATE of bug 6021
Product: Samba 3.2
Classification: Unclassified
Component: Client tools
3.2.3
x86 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 12:24 UTC by aragon
Modified: 2009-01-12 02:03 UTC (History)
0 users

See Also:


Attachments
Debug Log Level 10 for version 3.2.3 (6.69 KB, application/x-gzip)
2008-09-23 12:28 UTC, aragon
no flags Details
Debug Log Level 10 for version 3.0.14 (49.85 KB, application/x-gzip)
2008-09-23 12:29 UTC, aragon
no flags Details
smbclient //djhuti.domainname/C$ -c "archive 0; recurse; du" -d10 (5.58 KB, application/x-gzip)
2008-09-24 11:18 UTC, aragon
no flags Details
smbclient //djhuti.domainname/C$ -c "archive 1; recurse; du" -d10 (5.61 KB, application/x-gzip)
2008-09-24 11:25 UTC, aragon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description aragon 2008-09-23 12:24:20 UTC
After updating our Amanda Backup Server Amun running Debian/Etch from Samba 3.0.28 to 3.2.3 smbclient reports a size of 0 Bytes on some partitions.

amun:# smbclient //djhuti.domainname/systembackup -U domainname/backup -c "archive 0; recurse; du" -d1
Enter domainname/backup's password:
Domain=[DOMAINNAME] OS=[Windows Server 2003 R2 3790 Service Pack 2] Server=[Windows Server 2003 R2 5.2]
                56698 blocks of size 4194304. 49472 blocks available
Total number of bytes: 0


To compare here the output of the same command with smbclient 3.0.14a on another host running Debian/Sarge.

nuit:~$ smbclient //djhuti.datasysteme/systembackup -U datasysteme/backup -c "archive 0; recurse; du" -d1
Password:
Domain=[DATASYSTEME] OS=[Windows Server 2003 R2 3790 Service Pack 2] Server=[Windows Server 2003 R2 5.2]
                56698 blocks of size 4194304. 49472 blocks available
Total number of bytes: 15942706031

I will attach level 10 debug output from both commands.
This is maybe related to bug 5436.

Thanks,
Martin
Comment 1 aragon 2008-09-23 12:28:04 UTC
Created attachment 3611 [details]
Debug Log Level 10 for version 3.2.3

gzipped debug log of smbclient //djhuti.domainname/systembackup -U domainname/backup -c "archive 0; recurse; du" -d10
Comment 2 aragon 2008-09-23 12:29:34 UTC
Created attachment 3612 [details]
Debug Log Level 10 for version 3.0.14

gzipped debug log of smbclient //djhuti.domainname/systembackup -U
domainname/backup -c "archive 0; recurse; du" -d10
Comment 3 aragon 2008-09-24 11:12:20 UTC
After some additional testing I found that:

- smbclient 3.2.3 reports a size of 1537MB for Share //djhuti/C$, no matter if "archive 0" or "archive 1" is used. This drive contains 15GB of data.

- The size reported with "archive 1" did not change if I set or clear the "archiv bit" of some Files or a complete root directory recursively.

I append the level 10 log of both commands.
Comment 4 aragon 2008-09-24 11:18:27 UTC
Created attachment 3624 [details]
smbclient //djhuti.domainname/C$ -c "archive 0; recurse; du" -d10

Level 10 debug log of the following command.//djhuti.domainname/C$ contains 15GB of data, smbclient reports only 2GB with "archive 0"

amun:/home/guru# smbclient //djhuti.domainname/C$ -U domainname/backup -c "archive 0; recurse; du" -d10 -l /home/guru
Enter domainname/backup's password:
                49999 blocks of size 1048576. 41828 blocks available
Total number of bytes: 2145877442
Comment 5 aragon 2008-09-24 11:21:15 UTC
(In reply to comment #3)
> - smbclient 3.2.3 reports a size of 1537MB for Share //djhuti/C$, no matter if
> "archive 0" or "archive 1" is used. This drive contains 15GB of data.
Sorry, I mean 2046MB instead of 1537MB.
Comment 6 aragon 2008-09-24 11:25:21 UTC
Created attachment 3625 [details]
smbclient //djhuti.domainname/C$ -c "archive 1; recurse; du" -d10

Level 10 debug log of the following command.//djhuti.domainname/C$ contains
15GB of data, smbclient reports only 2GB with "archive 1". No matter how many archive bits are set or cleared.

amun:/home/guru# smbclient //djhuti.domainname/C$ -U domainname/backup -c
"archive 1; recurse; du" -d10 -l /home/guru
Enter domainname/backup's password:
                49999 blocks of size 1048576. 41828 blocks available
Total number of bytes: 2145741762
Comment 7 Jeremy Allison 2009-01-12 02:03:22 UTC

*** This bug has been marked as a duplicate of 6021 ***