Bug 5781 - Copy a Large amount files :The specified network name is no longer available
Copy a Large amount files :The specified network name is no longer available
Status: RESOLVED INVALID
Product: Samba 3.2
Classification: Unclassified
Component: File services
unspecified
Other Windows XP
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 21:59 UTC by zhanglq
Modified: 2008-09-24 01:20 UTC (History)
1 user (show)

See Also:


Attachments
error of samba copy files (2.09 KB, text/plain)
2008-09-24 01:09 UTC, zhanglq
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhanglq 2008-09-22 21:59:09 UTC
Server: RHEL5.1
    Samba:maybe any of 3.0.x
Client:Windows xp SP2
when i Map the remote share, using same connection details. Now copy is often 
fine, but sometimes will just fail with a "Cannot copy
<filename>: The specified network name is no longer available." and 
leave a zero-length file at the remote end.
Not infrequently, smbd processes are being left in an 'uninterruptible 
sleep' state.
Comment 1 Volker Lendecke 2008-09-22 23:58:54 UTC
If you can't kill those processes with kill -9, then it's a kernel bug or a hardware problem. What file system are you running on?

Volker
Comment 2 zhanglq 2008-09-23 00:19:21 UTC
Hope more detailed description will help:
1、my server and client both have  Gigabit Ethernet card
2、the samba share based on ext3 filesystem of lvm2 volume,
3、create one snapshot for this lvm2 volume.
4、then start  copy 5GB or more files to  this samba share
5、after about 10 minutes,the transfer rate goes to zero;  then Windows XP client said:"Cannot copy <filename>: The specified network name is no longer available"
Comment 3 Jeremy Allison 2008-09-23 00:23:27 UTC
If the smbd processes are stuck in a disk (uninterruptible) wait then it's a kernel bug or a hardware problem, not a Samba one. As Volker said, when the system is in this state try killing a "stuck" smbd with kill -9. If it doesn't die then you have a kernel or hardware problem, not a Samba one.
Jeremy. 
Comment 4 zhanglq 2008-09-23 00:41:38 UTC
(In reply to comment #3)
> If the smbd processes are stuck in a disk (uninterruptible) wait then it's a
> kernel bug or a hardware problem, not a Samba one. As Volker said, when the
> system is in this state try killing a "stuck" smbd with kill -9. If it doesn't
> die then you have a kernel or hardware problem, not a Samba one.
> Jeremy. 

1、It is very diffvult to say this is a kernel bug,because not use samba we can copy any size files to this ext3 volume(with snapshot),every time it works fine.
   We change Linux kernel to 2.6.19,the problem also exist.
   We change samba to 2.2.12,the problem also exist.
4、And also may not be a problem of hardware,bacause we chage hardware and the problem exist.
Comment 5 zhanglq 2008-09-23 02:13:11 UTC
My Summary Description of problem:
samba share based on a lvm2 volume with snapshot.
When Copy a Large amount files from Windows XP(SP2) or 2k3 to RHEL5.1 samba
share,after about 10 minutes transfer speed gose to zero,then windows Client
said:"Cannot copy <filename>: The specified network name is no longer
available".

Version-Release number of selected component (if applicable):
Any release of samba version V2 and V3.

How reproducible:
Steps to Reproduce:
1.create a lvm2 volume,and format this volume to ext3
2.create one or more snapshot to this volume
3.Use samba share one directory to client
3.use Windows XP or 2K3 Client copy large amount files(maybe 5GB or more) to
this samba server.
4.After about 10 minutes transfer speed gose to zero
5.Wait serveral mintues more,then windows Client said:"Cannot copy <filename>:
The specified network name is no longer available"

Additional info:
1.MY server and client both have  Gigabit Ethernet card
2.We change Linux kernel to 2.6.19,the problem also exist.
3.We change samba to 2.2.12,the problem also exist.
4.It may not be a problem of hardware,bacause we chage hardware and the
problem exist.

Comment 6 Volker Lendecke 2008-09-23 08:06:09 UTC
Can you kill the hanging processes with kill -9?

Volker
Comment 7 zhanglq 2008-09-23 20:19:56 UTC
(In reply to comment #6)
> Can you kill the hanging processes with kill -9?
> Volker

Yes, can kill samba process with "kill -9 ".
Comment 8 zhanglq 2008-09-23 22:34:47 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Can you kill the hanging processes with kill -9?
> > Volker
> Yes, can kill samba process with "kill -9 ".

Now,i change kernel to 2.6.26,and kcopyd of lvm2 died because of page alloc failed.
Try to kill -9 samba process:
1. smbd and nmbd run from service can be killed
2.smbd and nmbd run as samba lonin user can not be killed.
Comment 9 Volker Lendecke 2008-09-24 00:28:06 UTC
Ok. If you have unkillable smbd processes, there is nothing that Samba can do. This is a kernel or hardware problem.

Volker
Comment 10 zhanglq 2008-09-24 01:09:12 UTC
Created attachment 3621 [details]
error of samba copy files

here is the error log,kernel is 2.6.26.
Comment 11 zhanglq 2008-09-24 01:20:33 UTC
(In reply to comment #9)
> Ok. If you have unkillable smbd processes, there is nothing that Samba can do.
> This is a kernel or hardware problem.
> Volker

Thanks.
I agree with you,we suppose this maybe lvm2 or kernel error.