Bug 578 - spoolss_io_devmode(607) with Zebra printer driver V2.4
spoolss_io_devmode(607) with Zebra printer driver V2.4
Status: RESOLVED WONTFIX
Product: Samba 2.2
Classification: Unclassified
Component: Printing
2.2.5
All AIX
: P2 normal
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-07 03:17 UTC by Denis LAMBLIN
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis LAMBLIN 2003-10-07 03:17:06 UTC
We use SAMBA 2.2.5 on AIX 5.1 to share ZEBRA printers.
ZEBRA driver used is Zebra 105SL 200dpi V2.4.
The Zebra driver is installed on Windows2000 server and printer is connected 
like Remote printer. When we send a label to printer this error is written to 
log.smbd :

[2003/10/07 10:37:52, 0] rpc_parse/parse_spoolss.c:spoolss_io_devmode(607)
  spoolss_io_devmode: Unknown specversion in devicemode [0x0]
[2003/10/07 10:37:52, 0] rpc_parse/parse_spoolss.c:spoolss_io_devmode(608)
  spoolss_io_devmode: please report to samba-technical@samba.org!
[2003/10/07 10:37:52, 0] rpc_parse/parse_spoolss.c:spoolss_io_devmode(704)
  spoolss_io_devmode: I've parsed all I know and there is still stuff left|
[2003/10/07 10:37:52, 0] rpc_parse/parse_spoolss.c:spoolss_io_devmode(706)
  spoolss_io_devmode: available_space = [800], devmode_size = [1020]!
[2003/10/07 10:37:52, 0] rpc_parse/parse_spoolss.c:spoolss_io_devmode(707)
  spoolss_io_devmode: please report to samba-technical@samba.org!
[2003/10/07 10:37:52, 0] rpc_server/srv_spoolss.c:api_spoolss_open_printer_ex(72
)
  spoolss_io_q_open_printer_ex: unable to unmarshall SPOOL_Q_OPEN_PRINTER_EX.
[2003/10/07 10:37:52, 0] rpc_server/srv_pipe.c:api_rpcTNP(1200)
  api_rpcTNP: api_spoolss_rpc: SPOOLSS_OPENPRINTEREX failed.


The smb.conf file :
===================
[global]
        netbios name = xiet05
        netbios aliases = xiet05
        server string = xiet05
        security = SHARE
        encrypt passwords = Yes
        smb passwd file = /etc/samba/smbpasswd
        map to guest = Bad User
        username map = /etc/samba/smbusers
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        dns proxy = No
        guest account = smbadm
        printcap name = /etc/printcap
        printer admin = smbadm root
        printing = cups
        load printers = yes

[printers]
        comment = All Printers
        path = /var/spool/samba
        read only = No
        create mask = 0700
        guest ok = Yes
        printable = Yes
        print command = /usr/local/bin/lpr -P %p -o raw %s -r
        browseable = Yes

[print$]
        path = /home/smbadm
        write list = smbadm root
        guest ok = Yes

when we try to use the drivers upload the same error occurs.
We tried with a SAMBA on LINUX with same error.
Comment 1 Gerald (Jerry) Carter 2004-02-17 08:45:46 UTC
Sorry, but the 2.2 is not under development any longer.
If you can reproduce this bug against the latest 3.0 release, 
please reopen this bug and change the version in the report.
Thanks.
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:27:08 UTC
database cleanup