Bug 5779 - mount fails with return code -11 using clustered samba
mount fails with return code -11 using clustered samba
Product: Samba 3.0
Classification: Unclassified
Component: clustering
x64 Linux
: P3 regression
: none
Assigned To: Volker Lendecke
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2008-09-22 06:48 UTC by Michael Vitale
Modified: 2008-09-22 13:27 UTC (History)
0 users

See Also:

log file with debug 10 stuff in it (92.26 KB, text/plain)
2008-09-22 06:51 UTC, Michael Vitale
no flags Details
samba config file used (7.96 KB, text/plain)
2008-09-22 06:53 UTC, Michael Vitale
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Vitale 2008-09-22 06:48:06 UTC
I compiled the latest ctdb and samba_3_0_ctdb.  Right now I am just testing the samba part of it with clustering turned off in the smb.conf file, and I am getting these mount errors (-11) trying to mount a share on the local hard drive.  I am using linux kernel 2.6.22-1-amd64.

Here is the command that fails:
mount.cifs // /haha --verbose -o user=sambauser,domain=ics

The screen output:
 CIFS VFS: No response for cmd 117 mid 3
 CIFS VFS: cifs_mount failed w/return code = -11
mount error 11 = Resource temporarily unavailable

I ran with debug level 10.
I have attached the smb.conf and the smbd log file for your analysis.
Comment 1 Michael Vitale 2008-09-22 06:51:02 UTC
Created attachment 3607 [details]
log file with debug 10 stuff in it
Comment 2 Michael Vitale 2008-09-22 06:53:10 UTC
Created attachment 3608 [details]
samba config file used
Comment 3 Michael Vitale 2008-09-22 13:27:03 UTC
Closed this bug, since after recompiling, I don't get this problem anymore.  Although, I don't understand how it cropped in to begin with.