Bug 5762 - system inaccessible when joined through ADS with samba 3.0.28
system inaccessible when joined through ADS with samba 3.0.28
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.28a
Other Windows XP
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-15 07:48 UTC by Sagar
Modified: 2010-02-21 06:52 UTC (History)
2 users (show)

See Also:


Attachments
different logs (15.51 KB, text/plain)
2008-09-15 08:00 UTC, Sagar
no flags Details
samba log after inserting debug messages in code path in /lib/util_sock.c (136.67 KB, text/plain)
2008-09-16 01:43 UTC, Sagar
no flags Details
samba log after inserting debug messages in code path in /lib/util_sock.c (136.67 KB, text/plain)
2008-09-16 01:43 UTC, Sagar
no flags Details
Adding log with syslog only=no and log level 10 (134.33 KB, text/plain)
2008-09-16 02:26 UTC, Sagar
no flags Details
Adding log with syslog only=no and log level 10 (134.33 KB, text/plain)
2008-09-16 02:26 UTC, Sagar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sagar 2008-09-15 07:48:13 UTC
Don't know whether this was already asked on the mailing list but I couldn't find it so putting it down again. 

We have recently upgraded samba 3.0.14 to 3.0.28 and everything looked fine except the accessing share when joined ADS. 

I observe following log when tried to access the share using \\ip. I am able to join ADS successfully but I am not getting the login window when checked using \\ip. On contrary, if I specify \\ip\share, I am able to get the login prompt and everything works fine. Following is the log we get when tried to join using \\ip


Sep 11 21:57:58 forbear smbd[30908]: [2008/09/11 21:57:58, 0] auth/auth_util.c:create_builtin_administrators(792)
Sep 11 21:57:58 forbear smbd[30908]:  create_builtin_administrators: Failed to create Administrators
Sep 11 21:57:58 forbear smbd[30905]: [2008/09/11 21:57:58, 0] auth/auth_util.c:create_builtin_administrators(792)
Sep 11 21:57:58 forbear smbd[30905]:  create_builtin_administrators: Failed to create Administrators
Sep 11 21:57:58 forbear smbd[30905]: [2008/09/11 21:57:58, 0] auth/auth_util.c:create_builtin_users(758)
Sep 11 21:57:58 forbear smbd[30905]:  create_builtin_users: Failed to create Users
Sep 11 21:57:58 forbear smbd[30905]: [2008/09/11 21:57:58, 0] lib/util_sock.c:get_peer_addr(1232)
Sep 11 21:57:58 forbear smbd[30905]:  getpeername failed. Error was Transport endpoint is not connected
Sep 11 21:57:58 forbear smbd[30905]: [2008/09/11 21:57:58, 0] lib/util_sock.c:write_data(562)
Sep 11 21:57:58 forbear smbd[30905]:  write_data: write failure in writing to client 0.0.0.0. Error Connection reset by peer
Sep 11 21:57:58 forbear smbd[30905]: [2008/09/11 21:57:58, 0] lib/util_sock.c:send_smb(769)
Sep 11 21:57:58 forbear smbd[30905]:  Error writing 4 bytes to client. -1. (Connection reset by peer)
Sep 11 21:57:58 forbear smbd[30908]: [2008/09/11 21:57:58, 0] auth/auth_util.c:create_builtin_users(758)
Sep 11 21:57:58 forbear smbd[30908]:  create_builtin_users: Failed to create Users
Sep 11 21:57:58 forbear smbd[30908]: [2008/09/11 21:57:58, 0] lib/util_sock.c:get_peer_addr(1232)
Sep 11 21:57:58 forbear smbd[30908]:  getpeername failed. Error was Transport endpoint is not connected
Sep 11 21:57:58 forbear smbd[30908]: [2008/09/11 21:57:58, 0] lib/util_sock.c:write_data(562)
Sep 11 21:57:58 forbear smbd[30908]:  write_data: write failure in writing to client 0.0.0.0. Error Connection reset by peer
Sep 11 21:57:58 forbear smbd[30908]: [2008/09/11 21:57:58, 0] lib/util_sock.c:send_smb(769)
Sep 11 21:57:58 forbear smbd[30908]:  Error writing 4 bytes to client. -1. (Connection reset by peer)
Sep 11 21:58:08 forbear smbd[30909]: [2008/09/11 21:58:08, 0] auth/auth_util.c:create_builtin_administrators(792)
Sep 11 21:58:08 forbear smbd[30909]:  create_builtin_administrators: Failed to create Administrators
Sep 11 21:58:08 forbear smbd[30909]: [2008/09/11 21:58:08, 0] auth/auth_util.c:create_builtin_users(758)
Sep 11 21:58:08 forbear smbd[30909]:  create_builtin_users: Failed to create Users
Sep 11 21:58:08 forbear smbd[30909]: [2008/09/11 21:58:08, 0] lib/util_sock.c:get_peer_addr(1232)
Sep 11 21:58:08 forbear smbd[30909]:  getpeername failed. Error was Transport endpoint is not connected
Sep 11 21:58:08 forbear smbd[30909]: [2008/09/11 21:58:08, 0] lib/util_sock.c:write_data(562)
Sep 11 21:58:08 forbear smbd[30909]:  write_data: write failure in writing to client 0.0.0.0. Error Connection reset by peer
Sep 11 21:58:08 forbear smbd[30909]: [2008/09/11 21:58:08, 0] lib/util_sock.c:send_smb(769)
Sep 11 21:58:08 forbear smbd[30909]:  Error writing 4 bytes to client. -1. (Connection reset by peer)

When decoded through ethereal, it seems that NBNS which is netbios service name query is not requested when asked with share but plain ip request does request it.

1. samba-3.0.14a recives packet NBSS, NetBIOS Session service. But in case samba-3.0.28a before receiveing NBSS packets, it receives NBNS packets (NetBIOS Name Service) and server is able to respond to this request. 

2. In samba-3.0.28a, access to share using \\ip doen`t send any response to NBSS request, but access to share using \\ip\share is sending positive response to NBSS request. 
The ADS server is dual homed. And As mentioned above, in the same setup I am able to connect to \\ip using samba 3.0.14 but not in 3.0.28
Here are the logs:

Sep 10 23:56:56 foobar nmbd[31166]:   query_name_response: Multiple (2) responses received for a query on subnet 192.168.3.121 for name COCKBURN<1d>. 
Sep 10 23:56:56 foobar nmbd[31166]:   This response was from IP 192.168.3.2, reporting an IP address of 169.254.133.72. 
Sep 10 23:57:31 foobar winbindd[31170]: [2008/09/10 23:57:31, 0] lib/util_sock.c:read_socket_with_timeout(497) 
Sep 10 23:57:31 foobar winbindd[31170]:   read_socket_with_timeout: timeout read. read error = Connection reset by peer. 
Sep 10 23:57:31 foobar winbindd[31170]: [2008/09/10 23:57:31, 0] libsmb/clientgen.c:cli_receive_smb(112) 
Sep 10 23:57:31 foobar winbindd[31170]:   Receiving SMB: Server stopped responding 
Sep 10 23:57:31 foobar winbindd[31170]: [2008/09/10 23:57:31, 0] rpc_client/cli_pipe.c:rpc_api_pipe(790) 
Sep 10 23:57:31 foobar winbindd[31170]:   rpc_api_pipe: Remote machine storbridge2.cockburn.local pipe \NETLOGON fnum 0xdreturned critical error. Error was Read error: Connection reset by peer 
Sep 10 23:57:31 foobar winbindd[31169]: [2008/09/10 23:57:31, 1] nsswitch/winbindd_util.c:trustdom_recv(229) 
Sep 10 23:57:31 foobar winbindd[31169]:   Could not receive trustdoms 

After googling, I found several posts for blocking port 445 but that doesn't resolve the issue. 
Even in the client we enabled explicitly netbios over TCP/IP but doesn't help.

Thanks
Sagar
Comment 1 Sagar 2008-09-15 08:00:01 UTC
Created attachment 3580 [details]
different logs

Attached is the log of:
1. smb.conf
2. /var/log/message
3. /var/log/samba/samba.log
Comment 2 Sagar 2008-09-16 01:43:27 UTC
Created attachment 3585 [details]
samba log after inserting debug messages in code path in /lib/util_sock.c
Comment 3 Sagar 2008-09-16 01:43:51 UTC
Created attachment 3586 [details]
samba log after inserting debug messages in code path in /lib/util_sock.c
Comment 4 Sagar 2008-09-16 02:26:30 UTC
Created attachment 3587 [details]
Adding log with syslog only=no and log level 10

Attaching the log with more information
Comment 5 Sagar 2008-09-16 02:26:47 UTC
Created attachment 3588 [details]
Adding log with syslog only=no and log level 10

Attaching the log with more information
Comment 6 Sagar 2008-09-18 04:33:01 UTC
Another point to note that we are launching samba server through tcp server. We have observed that in some cases, when we start samba through tcp server, the issue is seen but when we start stand alone, we are not able to observe this
Comment 7 Sagar 2008-09-18 04:33:44 UTC
Did close this by mistake
Comment 8 Gerald (Jerry) Carter 2008-09-18 07:41:25 UTC
(In reply to comment #6)
> Another point to note that we are launching samba server through tcp server. We
> have observed that in some cases, when we start samba through tcp server, the
> issue is seen but when we start stand alone, we are not able to observe this
> 

I highly recommend against running smbd from [x]inetd.  I fyou can only reproduce this bug
under that operating environment, then I would say it's just another reason to run smbd
standalone.
Comment 9 Stefan Metzmacher 2010-02-21 06:52:52 UTC
Samba 3.0.x is not supported anymore.