Bug 5750 - SMB signing+KB955302+unable to open file share
SMB signing+KB955302+unable to open file share
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.31
x86 Windows XP
: P3 regression
: none
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-11 02:13 UTC by Feroz Ahmed
Modified: 2008-09-12 17:07 UTC (History)
0 users

See Also:


Attachments
smb.conf (1.09 KB, text/plain)
2008-09-11 02:15 UTC, Feroz Ahmed
no flags Details
Network Capture (6.52 KB, application/octet-stream)
2008-09-11 02:16 UTC, Feroz Ahmed
no flags Details
screen capture of Installed updated, os verson , network capture and log file with Debg level 101,smb.conf (174.14 KB, image/jpeg)
2008-09-11 10:31 UTC, Feroz Ahmed
no flags Details
log file with debug level 101 (194.96 KB, text/plain)
2008-09-11 10:34 UTC, Feroz Ahmed
no flags Details
screen capture of installed updates (68.81 KB, image/jpeg)
2008-09-11 10:35 UTC, Feroz Ahmed
no flags Details
windows vista OS version details (75.91 KB, text/plain)
2008-09-11 10:36 UTC, Feroz Ahmed
no flags Details
windows vista OS version details (75.91 KB, image/jpeg)
2008-09-11 10:36 UTC, Feroz Ahmed
no flags Details
Patch for 3.0.x. (2.00 KB, patch)
2008-09-11 14:16 UTC, Jeremy Allison
no flags Details
Network Capture (3.46 KB, application/octet-stream)
2008-09-12 08:39 UTC, Feroz Ahmed
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Feroz Ahmed 2008-09-11 02:13:25 UTC
Hi,
Im using windows Vista SP1 and when I installed KB955302 on vista machine im unable to open file share. Please refer the following link to download KB955302.
http://support.microsoft.com/?kbid=955302

This problem happens only when i set "server signing = auto" in smb.conf

Have attached my smb.conf and network trace for you reference.
This problem is 100% reproducable.
Comment 1 Feroz Ahmed 2008-09-11 02:15:07 UTC
Created attachment 3555 [details]
smb.conf
Comment 2 Feroz Ahmed 2008-09-11 02:16:19 UTC
Created attachment 3556 [details]
Network Capture

the attached network capture is taken when i was unable to open file share.
Comment 3 Stefan Metzmacher 2008-09-11 09:59:52 UTC
The problem seems to be that the reply to the 2nd session setup request (frame12)
isn't signed (it still has the BSRSPYL signature)

I can't reproduce with a modified smbtorture under make test...

Can you please upload a log file with debug level 101 (Note that might
contain the password hashes!)
Comment 4 Feroz Ahmed 2008-09-11 10:31:18 UTC
Created attachment 3560 [details]
screen capture of Installed updated, os verson , network capture and log file with Debg level 101,smb.conf

common.log file contains Debug level 101 logs
Comment 5 Feroz Ahmed 2008-09-11 10:34:18 UTC
Created attachment 3561 [details]
log file with debug level 101
Comment 6 Feroz Ahmed 2008-09-11 10:35:33 UTC
Created attachment 3562 [details]
screen capture of installed updates
Comment 7 Feroz Ahmed 2008-09-11 10:36:24 UTC
Created attachment 3563 [details]
windows vista OS version details
Comment 8 Feroz Ahmed 2008-09-11 10:36:29 UTC
Created attachment 3564 [details]
windows vista OS version details
Comment 9 Jeremy Allison 2008-09-11 13:51:18 UTC
Ok, looks like a bug in reporting guest credentials to the client. Looking in the log at line 3035 we see :

3035   register_vuid: (99,99) nobody vista LOCALHOST guest=1

because the username "SAD\vista" does not exist (see line :

 2966   check_ntlm_password:  Authentication for user [vista] -> [vista] FAILED with error NT_STATUS_NO_SUCH_USER

but the GUEST bit is not set in the reply packet (mid=384) for the sessionsetup. I'll look into the 3.0.x code for the problem and also test 3.2.x.
Jeremy.
Comment 10 Jeremy Allison 2008-09-11 14:00:59 UTC
Ok, found the bug. I'll attach a patch shortly - but you'll need to test this as I can't install that bloody hotfix on my vmware vista :-(.
Jeremy.
Comment 11 Jeremy Allison 2008-09-11 14:16:28 UTC
Created attachment 3566 [details]
Patch for 3.0.x.

Here's the patch for 3.0.x. This was already fixed in 3.2.x.
Jeremy.
Comment 12 Jeremy Allison 2008-09-11 16:41:39 UTC
Please let me know asap if this doesn't fix the problem - we may need to drop the signing bit on the response also. If you could test with 3.2.x that would also help.
Jeremy.
Comment 13 Feroz Ahmed 2008-09-12 07:45:14 UTC
Jeremy,
I tested 3.0.32+patch and 3.2.0 with windows vista SP1 and windows 2008 server.

With both the OS i was able to open file share..

I think this issue got fixed you fix.

I'll reopen this bug if I find any issues in feature.
Comment 14 Stefan Metzmacher 2008-09-12 08:33:20 UTC
Could you please send me a capture where it's working,
I'd like to understand what's going on on the wire:-)

I assumed samba4 fixed this different (and maybe wrong...)

See http://gitweb.samba.org/?p=samba.git;a=commitdiff;h=a89f9818180e8fb86
Comment 15 Feroz Ahmed 2008-09-12 08:39:23 UTC
Created attachment 3571 [details]
Network Capture

network capture after applying patch
Comment 16 Jeremy Allison 2008-09-12 17:07:58 UTC
Fixed in git trees.
Jeremy.