Bug 5724 - Samba v3.2.x with cluster support is incompilable under RHEL5/CentOS5 - ctdbd_conn.c
Samba v3.2.x with cluster support is incompilable under RHEL5/CentOS5 - ctdbd...
Product: Samba 3.2
Classification: Unclassified
Component: Build environment
x64 Linux
: P3 major
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2008-08-28 17:22 UTC by Abraham Alawi
Modified: 2008-09-07 16:13 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Abraham Alawi 2008-08-28 17:22:11 UTC
Building Samba 3.2.x with cluster support under RHEL5/CentOS5 doesn't want to work! I tried different vanilla sources & SRPMs but no luck at all, I always get the same error message. Any clues?

BTW, your binary RPM package (http://ctdb.samba.org/packages/redhat/RHEL5/samba-3.2.1-ctdb.46.x86_64.rpm) for RHEL5 requires 'libdmapi.so' which seems to be related to GPFS, I couldn't find anywhere.

Keep up the good work and thanks in advance.

[root@fs2 shared]# rpmbuild -bb --target=x86_64 /usr/src/redhat/SPECS/samba.spec 
Building target platforms: x86_64
Building for target x86_64
Compiling lib/replace/replace.c
Compiling lib/replace/snprintf.c
Compiling lib/replace/getpass.c
creating /usr/src/redhat/BUILD/samba-3.2.1/source/exports/libtalloc.syms
Compiling lib/tdb/common/tdb.c
Compiling lib/tdb/common/dump.c
Compiling lib/tdb/common/transaction.c
Compiling lib/tdb/common/error.c
Compiling lib/tdb/common/traverse.c
Compiling lib/tdb/common/freelist.c
Compiling lib/tdb/common/freelistcheck.c
Compiling lib/tdb/common/io.c
Compiling lib/tdb/common/lock.c
Compiling lib/tdb/common/open.c
creating /usr/src/redhat/BUILD/samba-3.2.1/source/exports/libtdb.syms
Compiling nsswitch/libwbclient/wbclient.c
Compiling nsswitch/libwbclient/wbc_util.c
Compiling nsswitch/libwbclient/wbc_pwd.c
Compiling nsswitch/libwbclient/wbc_idmap.c
Compiling nsswitch/libwbclient/wbc_sid.c
Compiling nsswitch/libwbclient/wbc_pam.c
Compiling nsswitch/wb_common.c
creating /usr/src/redhat/BUILD/samba-3.2.1/source/exports/libwbclient.syms
Compiling libsmb/libsmb_cache.c
Compiling libsmb/libsmb_compat.c
Compiling libsmb/libsmb_context.c
Compiling libsmb/libsmb_dir.c
Compiling libsmb/libsmb_file.c
Compiling libsmb/libsmb_misc.c
Compiling libsmb/libsmb_path.c
Compiling libsmb/libsmb_printjob.c
Compiling libsmb/libsmb_server.c
Compiling libsmb/libsmb_stat.c
Compiling libsmb/libsmb_xattr.c
Compiling libsmb/libsmb_setget.c
Compiling dynconfig.c
Compiling param/loadparm.c
Compiling param/params.c
Compiling param/util.c
Compiling lib/sharesec.c
Compiling lib/ldap_debug_handler.c
Compiling registry/reg_api.c
Compiling registry/reg_dispatcher.c
Compiling registry/reg_cachehook.c
Compiling registry/regfio.c
Compiling registry/reg_objects.c
Compiling registry/reg_util.c
Compiling lib/util_reg_api.c
Compiling lib/util_nttoken.c
Compiling registry/reg_backend_db.c
Compiling registry/reg_init_basic.c
Compiling registry/reg_backend_smbconf.c
Compiling registry/reg_init_smbconf.c
Compiling lib/smbconf/smbconf.c
Compiling lib/smbconf/smbconf_util.c
Compiling lib/smbconf/smbconf_reg.c
Compiling lib/smbconf/smbconf_txt.c
Compiling lib/smbconf/smbconf_init.c
Compiling lib/privileges_basic.c
Compiling lib/messages.c
Compiling librpc/gen_ndr/ndr_messaging.c
Compiling lib/messages_local.c
Compiling lib/messages_ctdbd.c
Compiling lib/packet.c
Compiling lib/ctdbd_conn.c
Compiling lib/talloc_stack.c
lib/ctdbd_conn.c: In function 'ctdbd_register_ips':
lib/ctdbd_conn.c:1184: error: storage size of 'p' isn't known
lib/ctdbd_conn.c:1184: warning: unused variable 'p'
The following command failed:
gcc -I. -I/usr/src/redhat/BUILD/samba-3.2.1/source  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE  -I/usr/src/redhat/BUILD/samba-3.2.1/source/iniparser/src -Iinclude -I./include  -I. -I. -I./lib/replace -I./lib/talloc -I./lib/tdb/include -I./libaddns -I./librpc -DHAVE_CONFIG_H  -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Iinclude -I./include -I. -I. -I./lib/replace -I./lib/talloc -I./lib/tdb/include -I./libaddns -I./librpc -I./popt -DLDAP_DEPRECATED   -I/usr/include/include -I/usr/src/redhat/BUILD/samba-3.2.1/source/lib -D_SAMBA_BUILD_=3 -fPIC -c lib/ctdbd_conn.c -o lib/ctdbd_conn.o
Compiling lib/interfaces.c
Compiling lib/rbtree.c
make: *** [lib/ctdbd_conn.o] Error 1
make: *** Waiting for unfinished jobs....
error: Bad exit status from /var/tmp/rpm-tmp.8227 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.8227 (%build)
Comment 1 Volker Lendecke 2008-08-29 00:50:37 UTC
For compiling, do you have the ctdb package, in particular the ctdb header files, installed?

Comment 2 Abraham Alawi 2008-09-07 16:13:56 UTC
Yes, CTDB was installed along with the header files but apparently the one I installed wasn't from your server. I removed it and installed yours, it's compiled with no problems.