Bug 5719 - Missing pscript.hlp file - cupsaddsmb goes to infinite loop
Missing pscript.hlp file - cupsaddsmb goes to infinite loop
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Config Files
3.2.1
x64 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
http://www.cups.org/str.php?L2901
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 01:01 UTC by Jari Aalto
Modified: 2008-08-26 01:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jari Aalto 2008-08-26 01:01:40 UTC
Please see original report: http://www.cups.org/str.php?L2901

Running command:

  cupsaddsmb -v -H localhost -U root -a

Running command: smbclient //localhost/print$ -N -A /tmp/489f07c546c76 -c 'mkdir W32X86;put /tmp/489f07bba7b7f W32X86/printer.ppd;put /usr/share/cups/drivers/ps5ui.dll W32X86/ps5ui.dll;put /usr/share/cups/drivers/pscript.hlp W32X86/pscript.hlp;put /usr/share/cups/drivers/pscript.ntf W32X86/pscript.ntf;put /usr/share/cups/drivers/pscript5.dll W32X86/pscript5.dll'
Domain=[HOST] OS=[Unix] Server=[Samba 3.2.0]
NT_STATUS_OBJECT_NAME_COLLISION making remote directory \W32X86
putting file /tmp/489f07bba7b7f as \W32X86/printer.ppd (3439.1 kb/s) (average 3439.1 kb/s)
putting file /usr/share/cups/drivers/ps5ui.dll as \W32X86/ps5ui.dll (6500.0 kb/s) (average 5793.6 kb/s)
/usr/share/cups/drivers/pscript.hlp does not exist
putting file /usr/share/cups/drivers/pscript.ntf as \W32X86/pscript.ntf (7302.5 kb/s) (average 7005.3 kb/s)
putting file /usr/share/cups/drivers/pscript5.dll as \W32X86/pscript5.dll (7085.9 kb/s) (average 7031.6 kb/s)

Goes to infinite loop. According to the CUPS bug tracker[1], this is problem with Samba installation: "Samba, for some reason, isn't seeing your pscript.hlpfile. Please file a bug with the Samba folks, including the information you supplied to us so they know how to reproduce it."

-----------------------------------------------------------------------
UNAME: Linux host 2.6.25-2-686 #1 SMP Fri Jul 18 17:46:56 UTC 2008 i686 GNU/Linux
OS   : Debian/testing
CUPS : 1.3.8-1

[Content of current directory where command cupsaddsmb was run] The files
were copied from Windows XP and per cupsaddsmb(8) manual page's
instructions.

$ ls -la
total 1412
drwxr-xr-x 2 root root   4096 2008-08-10 18:11 .
drwxr-xr-x 3 root root   4096 2008-08-10 18:08 ..
-rwxr-xr-x 1 root root 133120 2008-08-10 18:08 ps5ui.dll
-rwxr-xr-x 1 root root 464384 2008-08-10 18:08 pscript5.dll
-rwxr-xr-x 1 root root  26038 2008-08-10 18:08 pscript.hlp 
-rwxr-xr-x 1 root root 792644 2008-08-10 18:08 pscript.ntf

cups* files are from the http://www.cups.org/windows
and manually installed with

   install -m 644 i386/* /usr/share/cups/drivers/

$ ls -la /usr/share/cups/drivers/
drwxr-xr-x  2 root root   4096 2008-08-10 18:11 .
drwxr-xr-x 12 root root   4096 2008-08-10 16:49 ..
-rw-r--r--  1 root root    803 2008-08-10 17:27 cups6.inf
-rw-r--r--  1 root root     72 2008-08-10 17:27 cups6.ini
-rw-r--r--  1 root root   9529 2008-08-10 17:27 cups6.ppd
-rw-r--r--  1 root root  12568 2008-08-10 17:27 cupsps6.dll
-rw-r--r--  1 root root  13672 2008-08-10 17:27 cupsui6.dll
-rw-r--r--  1 root root 133120 2008-08-10 18:11 ps5ui.dll
-rw-r--r--  1 root root 464384 2008-08-10 18:11 pscript5.dll
-rw-r--r--  1 root root  26038 2008-08-10 18:11 pscript.hlp 
-rw-r--r--  1 root root 792644 2008-08-10 18:11 pscript.ntf
Comment 1 Jari Aalto 2008-08-26 01:30:02 UTC
(In reply to comment #0)
> Please see original report: http://www.cups.org/str.php?L2901
> 
> Running command:
> 
>   cupsaddsmb -v -H localhost -U root -a
> /usr/share/cups/drivers/pscript.hlp does not exist
> putting file /usr/share/cups/drivers/pscript.ntf as \W32X86/pscript.ntf (7302.5
> [Content of current directory where command cupsaddsmb was run] The files
> were copied from Windows XP and per cupsaddsmb(8) manual page's
> instructions.
> 
> $ ls -la
> total 1412
> drwxr-xr-x 2 root root   4096 2008-08-10 18:11 .
> drwxr-xr-x 3 root root   4096 2008-08-10 18:08 ..
> -rwxr-xr-x 1 root root 133120 2008-08-10 18:08 ps5ui.dll
> -rwxr-xr-x 1 root root 464384 2008-08-10 18:08 pscript5.dll
> -rwxr-xr-x 1 root root  26038 2008-08-10 18:08 pscript.hlp 
> -rwxr-xr-x 1 root root 792644 2008-08-10 18:08 pscript.ntf

It turns out that there was somehow extra space at the end of file name.

$ ls -la | cat -A

drwxr-xr-x 2 root root   4096 2008-08-26 09:28 .$
drwxr-xr-x 3 root root   4096 2008-08-10 18:08 ..$
-rw-r--r-- 1 root root     74 2008-08-26 09:24 cups-install.sh$
-rwxr-xr-x 1 root root 133120 2008-08-10 18:08 ps5ui.dll$
-rwxr-xr-x 1 root root 464384 2008-08-10 18:08 pscript5.dll$
-rwxr-xr-x 1 root root  26038 2008-08-10 18:08 pscript.hlp $
-rwxr-xr-x 1 root root 792644 2008-08-10 18:08 pscript.ntf$

After correcting the name, the install proceeds as expected.
Closing bug.