Bug 5710 - net rpc changetrustpw succeeds but breaks membership
net rpc changetrustpw succeeds but breaks membership
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Domain Control
3.2.2
Other Linux
: P3 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-21 10:45 UTC by Guenther Deschner
Modified: 2008-10-30 09:44 UTC (History)
1 user (show)

See Also:


Attachments
fix password change (3.67 KB, patch)
2008-08-21 10:48 UTC, Guenther Deschner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2008-08-21 10:45:04 UTC
When changing a machine password in W2k3 using "net rpc changetrustpw" (or it's rpcclient equivalent), the change succeeds but the credential chain is broken afterwards.

The fix is to use NetrServerPasswordSet2 when support for it is negotiated.
Comment 1 Guenther Deschner 2008-08-21 10:48:30 UTC
Created attachment 3500 [details]
fix password change

tested only with NT4 and W2k3 for now.
Comment 2 Guenther Deschner 2008-08-21 17:06:47 UTC
Fix in 3-2, 3-3 and 3-devel.
Comment 3 Guenther Deschner 2008-10-30 09:44:37 UTC
*** Bug 5855 has been marked as a duplicate of this bug. ***