Bug 5670 - [PATCH] Packaging script fix for Solaris 10
[PATCH] Packaging script fix for Solaris 10
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Packaging
3.2.0
All Solaris
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 07:22 UTC by Michal Ludvig
Modified: 2012-10-10 07:20 UTC (History)
2 users (show)

See Also:


Attachments
Proposed patch (3.31 KB, patch)
2008-08-05 07:23 UTC, Michal Ludvig
kseeger: review? (ira)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Ludvig 2008-08-05 07:22:45 UTC
On Solaris 10, both x86 and Sparc, the script provided in samba-3.2.0/packaging/Solaris doesn't work correctly and the README needs some fixes as well. 

Attached patch fixes the build script to work on default Solaris 10 installation. Please apply.
Comment 1 Michal Ludvig 2008-08-05 07:23:33 UTC
Created attachment 3454 [details]
Proposed patch
Comment 2 Björn Jacke 2012-09-13 22:32:19 UTC
though quite late, this has gone to master now. I just deleted the commented out echo lines. If you have packaging fixes for the latest releases, let us know. We definetely try to commit them faster next time ;-)

Karo: feel free to pick the commit "packaging: apply some solaris packaging fixes" to the release branches as well.
Comment 3 Karolin Seeger 2012-09-17 09:51:44 UTC
Re-assigning to Ira for patch review.
Ira, please feel free to re-assign.
Comment 4 Ira Cooper 2012-09-17 16:15:35 UTC
I don't know enough about Sys5r4 packaging to get review this.  (Nor samba 3.2.0!)

-Ira
Comment 5 Björn Jacke 2012-09-17 18:39:19 UTC
in cases like this (packaging fix which none of us uses) we can only see if it "looks sane" what the change does or not. We cannot do more about this.
Comment 6 Michal Ludvig 2012-09-17 21:15:36 UTC
Guys

The original poster here... 

I guess after 4+ years after patch submission you can just close it as won't fix. I doubt anyone is going to package Samba 3.2 for Solaris 10 anyway. If anything it would be a newer Samba or newer Solaris.

Close it, no problem, I don't care about this one at all ;)

Cheers!

Michal
Comment 7 Karolin Seeger 2012-09-18 06:42:25 UTC
Closing out bug report as requested by the reporter.

Thanks!
Comment 8 Karolin Seeger 2012-10-10 07:20:45 UTC
Patch has been pushed to autobuild-v4-0-test.