Bug 5651 - vfs objects = streams_xattr didn't work correctly. It says Network Is Busy
vfs objects = streams_xattr didn't work correctly. It says Network Is Busy
Status: RESOLVED DUPLICATE of bug 7537
Product: Samba 3.2
Classification: Unclassified
Component: VFS Modules
3.2.0
Other Other
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 07:08 UTC by Strizhevsky Alexander
Modified: 2012-08-22 09:38 UTC (History)
3 users (show)

See Also:


Attachments
Log and smb.conf (38.61 KB, application/x-gzip)
2008-07-31 00:01 UTC, Strizhevsky Alexander
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Strizhevsky Alexander 2008-07-30 07:08:23 UTC
This fix with vfs objects = streams_xattr didn't work correctly for me. 
When I setup it, i didn's see shte existing Identifier files, but I can't copy downloaded from the internet file to the server. 
It says Network Is Busy
Comment 1 Volker Lendecke 2008-07-30 07:31:41 UTC
Please upload your smb.conf and a debug level 10 log of smbd leading to this failure.

Thanks,

Volker
Comment 2 Strizhevsky Alexander 2008-07-31 00:01:07 UTC
Created attachment 3448 [details]
Log and smb.conf

File Keys.zip don't copy directory 111, Net Busy.
Comment 3 TAKAHASHI Motonobu 2008-11-15 09:18:33 UTC
I sometimes see this error message when writing to altinative data streams, but if I retry, writing is successfull.
Comment 4 TAKAHASHI Motonobu 2008-11-15 09:30:22 UTC
Error log

[2008/11/16 00:24:37,  3] smbd/oplock_linux.c:linux_set_kernel_oplock(145)
  linux_set_kernel_oplock: got kernel oplock on file test4.txt, file_id = 801:c7
a0c gen_id = 22
[2008/11/16 00:24:37,  3] smbd/process.c:process_smb(1549)
  Transaction 166 of length 63 (0 toread)
[2008/11/16 00:24:37,  3] smbd/process.c:switch_message(1361)
  switch message SMBreadX (pid 3233) conn 0x80639da8
[2008/11/16 00:24:37,  3] smbd/reply.c:send_file_readX(3250)
  send_file_readX fnum=6870 max=12 nread=12
[2008/11/16 00:24:47,  3] smbd/process.c:process_smb(1549)
  Transaction 167 of length 122 (0 toread)
[2008/11/16 00:24:47,  3] smbd/process.c:switch_message(1361)
  switch message SMBntcreateX (pid 3233) conn 0x80639da8
[2008/11/16 00:24:47,  3] smbd/dosmode.c:unix_mode(124)
  unix_mode(test4.txt) returning 0744
[2008/11/16 00:24:47,  2] smbd/open.c:open_file(407)
  local opened file test4.txt read=No write=No (numopen=2)
[2008/11/16 00:24:47,  3] smbd/dosmode.c:unix_mode(124)
  unix_mode(test4.txt:test4) returning 0744
[2008/11/16 00:24:47,  3] smbd/open.c:open_file(318)
  Error opening file test4.txt:test4 (NT_STATUS_NETWORK_BUSY) (local_flags=66) (
flags=578)
[2008/11/16 00:24:47,  2] smbd/close.c:close_normal_file(586)
  local closed file test4.txt (numopen=1) NT_STATUS_OK
[2008/11/16 00:24:47,  3] smbd/error.c:error_packet_set(61)
  error packet at smbd/nttrans.c(532) cmd=162 (SMBntcreateX) NT_STATUS_NETWORK_B
USY
Comment 5 Justin Maggard 2009-01-06 16:07:13 UTC
I believe this is related to oplocks.  Try to set "kernel oplocks = no" or "oplocks = no".  Otherwise, it looks like you'll need to use streams_depot for now.
Comment 6 Guenther Deschner 2009-08-06 08:42:03 UTC
Volker, any idea whether this has been resolved already ?
Comment 7 Volker Lendecke 2009-08-06 10:29:50 UTC
Haven't really looked yet, sorry.

Volker
Comment 8 Volker Lendecke 2009-08-30 04:54:23 UTC
Ok, looked at it. streams_xattr as it stands right now is incompatible with kernel oplocks. Please set "kernel oplocks = no".

The fix is not trivial, but I'd like you to try this setting as a workaround.

Thanks,

Volker
Comment 9 Björn Jacke 2012-08-22 09:38:09 UTC

*** This bug has been marked as a duplicate of bug 7537 ***