Bug 5618 - Solaris 9 AD member server dumps core
Solaris 9 AD member server dumps core
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: File services
3.2.0
Sparc Solaris
: P3 major
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
http://urban.csuohio.edu/~bob/samba_3...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-16 12:15 UTC by Robert M Martel
Modified: 2008-07-18 10:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert M Martel 2008-07-16 12:15:11 UTC
Samba 3.2 built on Sun Sparc Solaris 9 using gcc 3.4.6.  Machine is an Active Directory member server.  Configuration was working under Samba 3.0.31.  

Samba 3.2 worked on this platform as a stand-alone samba server without these issues.

Drives mapped from this server often show as "disconnected" on the windows client - but will always reconnect when accessed.

Attempts to create, rename, or edit files on the share result in errors along the line of "Specified network name is no longer available."

Samba configuration file at 
http://urban.csuohio.edu/~bob/samba_3.2.0/try1/smb.conf

sample from log file after mapping a drive on a client PC is below.  Full log file can be found at 
http://urban.csuohio.edu/~bob/samba_3.2.0/try1/smblog.137.148.92.196
I tried to run gdb against the process that dumped core but was unsuccessful.


[2008/07/16 12:58:22, 10] smbd/open.c:open_file_ntcreate(1383)
  open_file_ntcreate: fname=., after mapping access_mask=0x81
[2008/07/16 12:58:22,  5] smbd/files.c:file_new(121)
  allocated file structure 981, fnum = 5077 (1 used)
[2008/07/16 12:58:22, 10] lib/dbwrap_tdb.c:db_tdb_fetch_locked(100)
  Locking key 00000000008000010000
[2008/07/16 12:58:22, 10] lib/dbwrap_tdb.c:db_tdb_fetch_locked(129)
  Allocated locked data 0x65b7b8
[2008/07/16 12:58:22,  0] lib/fault.c:fault_report(40)
  ===============================================================
[2008/07/16 12:58:22,  0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 10 in pid 10139 (3.2.0)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2008/07/16 12:58:22,  0] lib/fault.c:fault_report(43)
  
  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2008/07/16 12:58:22,  0] lib/fault.c:fault_report(44)
  ===============================================================
[2008/07/16 12:58:22,  0] lib/util.c:smb_panic(1666)
  PANIC (pid 10139): internal error
Comment 1 Volker Lendecke 2008-07-16 14:04:59 UTC
This looks very similar to the one in 5512 where I proposed the fix with https://bugzilla.samba.org/attachment.cgi?id=3389. Did you try that?

If that did not help, you know the procedure: Compile with -g and send a backtrace :-)

Volker
Comment 2 Robert M Martel 2008-07-16 14:28:18 UTC
I did not try the patches from 5512 - I thought about it, but decided to not "self-medicate."  I will do that now.  I had just fixed the spelling of "panic action" in the smb.conf file and grabbed a back trace on the crashed process.  I'll add that to the ~bob/samba_3.2.0/try1/ directory for completeness.

-Bob

Comment 3 Robert M Martel 2008-07-16 14:56:08 UTC
Rebuilt 3.2 using the Solaris alignment patch provided by Volker.  I am no longer seeing the issues I described above.  I will continue to test the machine.

Comment 4 Volker Lendecke 2008-07-18 10:20:03 UTC
Confirmed fixed