Bug 5616 - no connection to a share
no connection to a share
Status: CLOSED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: File services
3.2.0
Sparc Windows 2000
: P3 major
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-16 00:53 UTC by Ralf Weinert
Modified: 2008-07-31 00:54 UTC (History)
0 users

See Also:


Attachments
no connection to a shre (263.30 KB, application/x-gzip)
2008-07-16 00:56 UTC, Ralf Weinert
no flags Details
no share connection (61.42 KB, application/x-gzip)
2008-07-24 01:14 UTC, Ralf Weinert
no flags Details
proposed patch (1.65 KB, patch)
2008-07-28 11:07 UTC, Volker Lendecke
no flags Details
no share connection (924.15 KB, application/x-gzip)
2008-07-29 08:55 UTC, Ralf Weinert
no flags Details
no share connection (924.15 KB, application/x-gzip)
2008-07-29 09:00 UTC, Ralf Weinert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Weinert 2008-07-16 00:53:12 UTC
when a client (Windows 200) tries to get a connection to a share over the samba server (3.2.0) I only see in the Windows explorer the icon for the wanted share. but as soon as I try to get the subdirectories of that share the explorer tells me that this connection does not work. In the samba logfile I can read the message:

Libsmb/smb_signing.c:srv_check_incoming_message(754)
srv_check_incoming_message: BAD SIG: seq 2 got SMB signature of

the last Samba version I used was 3.0.30 this one works without any problems

I have a zip-file containing the logged messages (level 10) and the config file, bit I don't know where to sent.

the samba server is a E450 running Solaris8
Comment 1 Ralf Weinert 2008-07-16 00:56:31 UTC
Created attachment 3413 [details]
no connection to a shre

Okay forget my last input, I found a way to sent my file
Comment 2 Karolin Seeger 2008-07-22 14:59:04 UTC
Please remove the settings for IPC$ from your smb.conf and try again.

The problem is that the client 129.103.112.105 ist not allowed to connect to IPC$:

[2008/07/15 13:42:26,  4] smbd/reply.c:reply_tcon_and_X(653)
  Client requested device type [?????] for share [IPC$]
[2008/07/15 13:42:26,  5] smbd/service.c:make_connection(1376)
  making a connection to 'normal' service ipc$
[2008/07/15 13:42:26,  3] lib/access.c:check_access(389)
  check_access: no hostnames in host allow/deny list.
[2008/07/15 13:42:26,  0] lib/access.c:check_access(410)
  Denied connection from  (129.103.112.105)
[2008/07/15 13:42:26,  3] smbd/error.c:error_packet_set(61)
  error packet at smbd/reply.c(662) cmd=117 (SMBtconX) NT_STATUS_ACCESS_DENIED

Marking bug report as invalid.
Please re-open if it still doesn't work without the IPC$ settings.
Comment 3 Ralf Weinert 2008-07-24 01:12:22 UTC
Hi,
although I removed the settings for IPC$, the share does not work properly.
After the connection succeeded, the next try to dive into the connected directory I get the message the connection is no longer available. I put a logfile to my report.
Comment 4 Ralf Weinert 2008-07-24 01:14:44 UTC
Created attachment 3420 [details]
no share connection
Comment 5 Volker Lendecke 2008-07-28 11:07:05 UTC
Created attachment 3426 [details]
proposed patch

The attached patch fixes the bug for me, can you try that?

Volker
Comment 6 Volker Lendecke 2008-07-28 11:09:05 UTC
Without the attached patch I could reproduce the bug, with the patch it works for me. So I'm closing it, but feel free to re-open if the patch does not help.

Thanks for the bug report and the log files,

Volker
Comment 7 Ralf Weinert 2008-07-29 08:55:48 UTC
Created attachment 3436 [details]
no share connection
Comment 8 Ralf Weinert 2008-07-29 09:00:04 UTC
Created attachment 3437 [details]
no share connection
Comment 9 Volker Lendecke 2008-07-29 09:57:20 UTC
Ok, the signing bug is gone. Does it work now?

Volker
Comment 10 Volker Lendecke 2008-07-29 10:00:46 UTC
Ah, okay, just found the panic. Can you try the patch from bug 5512?

Thanks,

Volker
Comment 11 Ralf Weinert 2008-07-31 00:54:23 UTC
Hi, the patched version 3.2.0 is running fine.

The bug can be closed.

Thanks