Bug 5590 - Stripping of libsmbclient.a fails with some strip versions when using --enable-shared-libs=no
Stripping of libsmbclient.a fails with some strip versions when using --enabl...
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Build environment
3.2.0
Other Linux
: P3 normal
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-07 04:11 UTC by Karolin Seeger
Modified: 2008-09-04 09:13 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karolin Seeger 2008-07-07 04:11:06 UTC
If --enable-shared-libs=no is set, stripping of libsmbclient.a fails with some versions of strip (RHEL3+4, Debian Sarge).
Comment 1 Michael Adam 2008-07-07 04:20:53 UTC
Ok, the problem is that libtalloc.a is linked into libsmbclient.a, and some versions of strip seem to have a bug when s/th like this happens.

libsmbsharemodes.a has the same problem linking in libtdb.a ...

working on a fix...
Comment 2 Michael Adam 2008-07-07 07:55:45 UTC
Fixed in v3-2-test with

4fc57a0a90390ede1161fd6f231ea274c9c74b20 for libsmbsharemodes and
dcf986937ccf5e6947c4214aa0838733ed7f3b9b for libsmbclient

fix for v3-3-test coming as part of bigger rewrite.
Comment 3 John H Terpstra 2008-07-07 13:31:35 UTC
test
Comment 4 Michael Adam 2008-07-07 13:33:04 UTC
I just noticed that libaddns.a has the same problem.
fixed in v3-2-test with 396310775e6
Comment 5 Michael Adam 2008-07-07 14:40:14 UTC
Also fixed in v3-3-test with:

76f9e2e646 - libsmbsharemodes
4d6edcb2c8 - libaddns
bae7bd4bba - libsmbclient

these patches have not been cherry-picked (into one direction or another) since the 3-3-test patches are on top of quite a few changes to the library build system.

Michael
Comment 6 Karolin Seeger 2008-07-22 14:53:20 UTC
Problem is fixed for me, thanks obnox! :-)
Closing out bug report.
Comment 7 Michael Adam 2008-08-20 02:50:22 UTC
This problem has been re-introduced by commit

6c33c620072d641fc19ca0224c16af75f6cd7e9e (v3-3-test)
and
41d440c3198752281556699cc9744b490b9b0a5e (v3-2-test)

Michael
Comment 8 Michael Adam 2008-08-20 02:51:02 UTC
We need to really fix the Makefile by untangling object colletions and static libs...
Comment 9 Michael Adam 2008-08-20 18:01:11 UTC
I *think* I have fixed this in v3-devel, v3-3-test and v3-2-test.
By linking in Objects instead of static libs (if linking statically).
Comment 10 Karolin Seeger 2008-09-04 09:13:26 UTC
Works for me!
Thanks for the fix!

Closing out bug report.